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INTRODUCTION

Welcome to Can-Pay's Grand Master Suite Schedule Module. The Schedule

Module is aWindows/OS2 program, and uses the standardWindows features which

make it simple to learn and use. The Schedule Module meets all your scheduling

needs by providing the facilities to schedule employee work time and employee

leave time such as vacation time, sick time, time off in lieu, training time and other

leave time.

Schedule Module

The Schedule Module uses organization chart structures to prepare schedules. The

organization chart positions must be marked as schedulable in order to be used by the

Schedule Module.

The organization chart must be used to describe departments for the �auto� schedule

functions. The organization chart provides the facilities to describe the positions to

fill, and the time and qualification requirements for those positions.

The Schedule Module provides the ability to assign the following attributes to a

scheduled time segment:

Field Description

Date The date that the time segment starts.

Start Time The starting time for the segment.

Stop Time The stopping time for the segment.

Shift Indicates the shift code for the segment (shifts provide a standard start
and stop time, and break times).

Premium Indicates the special premium codes for a segment.

Position Indicates the position code for the segment.

Reason Indicates the optional reason for the time segment.

G/L Distribution Optional general ledger labour distribution for the segment
(GMSUITE).

Department Indicates the department code (GMII).

Account Indicates the account code (GMII).

Sub Account Indicates the sub account (GMII).

Area Indicates the work area (JOBCOST).

Sub Area Indicates the work sub area (JOBCOST).

Activity Indicates the work activity (JOBCOST).

Sub Activity Indicates the work sub activity (JOBCOST).
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Employee Data

Standard Data

The Standard Employee Data recording functions are:

n Name and address data.

n Leave Time - inclusive vacation, sick time, training, time off in lieu, and other
time off.

n Incidents - includes accidents,union grievances, labour board disputes, and
other incidents.

n Availability - time available for work.

n Skills - records skills and certifications.

n Equipment Assignments - includes tool kits, safety equipment, and other
company owned equipment.

n Automotive - includes parking spaces, and company vehicle assignments

n Company Plans - includes profit sharing, share purchase, and saving bond
plans.

n Position Assignments - employee job assignments.

n Evaluations - employee performance evaluations.

User Defined Employee Data

The Schedule Module provides the facilities to define any number of additional data

categories for employees. Each data category may contain up to 100 data fields.

Each defined data category has an individual update screen.

Additional screens may be defined that incorporate data from several data categories

including system defined data categories.
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Inserting a New Payroll

The Insert option from the select payroll program will allow you to create a new

payroll. The following dialog box appears:

Type in the name of the new payroll and select the OK button.

The GrandMaster payroll file update dialog box will appear as follows:

Type in the payroll name, description, and path to the payroll and select OK from the

file menu.

F Click on the box to the left of the enable password if you wish to password protect the
payroll.
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Passwords

If you have selected ENABLE password the following dialog will appear:

Enter your desired password and then retype the password again in the confirm field.

F The password will be shown as *'s on the screen as you are typing for security reasons.

Please refer to the Administration manual for additional information concerning

passwords, security and entitlements.
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Set Search Technique

Once you have chosen the payroll that youwish toworkwith youmay prefer to set an

alternate search technique for accessing employees within the selected payroll. The

system default search technique is alphabetic surname search.

If the Set Search Technique option is selected from the File menu, then the

following screen will appear:

Employees on the system may be accessed through three different techniques:

n Employee Name- The employee name or a portion of the employee name may
be entered. The system will provide a list of the names that match the portion
entered. The name matching process requires that the last name be entered first,
given name last. When a name is entered the name must be preceded by the “%”
character, or the system option for employee search must be set for employee
name search.

n Badge Number - The employee badge number may be used to locate an
employee. The badge number is a left justified 10 character alphanumeric field.
When a badge number is entered the number must be preceded by the “@”
character or the system option for employee search must be set for badge
number search.

n Employee Number - The employee number may be used to locate an
employee. The employee number search may only be used when a payroll has
been selected. When an employee number is entered the number must be
preceded by the “#” character or the system option set for employee search must
be set for employee number search.
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F When employee group is in effect the search for an employee is restricted to the
selection group.

Each user may save their preference for a search technique.

F When the preferred search is employee number the system will require the selection of
a payroll to search for employees.

When a function offers a next employee or prior employee option the order of

presentation for the employees will depend on the search technique in effect.
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MANAGING EMPLOYEE GROUPS

The Main Human Resource menu provides facilities that operate on a group of

employees. The group may be all employees known to the system, all employees in a

particular payroll, or an employee selection group.

All operations regarding the management of employee groups are available in the

GroupManagement menu from the main menu bar. TheGroupManagement menu

appears as follows:

The options available to the user are:

n define and maintain employee selection groups

n enable/disable an employee group for scheduling use
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Selection Groups

A selection group is a list of employees that may be used to control processing in the

Payroll, Human Resources, Scheduling, and Time Keeping modules.

A selection group is created through the Group Management option.

A selection group may be a dynamic or a fixed group.

Dynamic Groups

A dynamic group is defined by a set of conditions that determine the employees that

are members of the group.

Each time the group is loaded the load process scans the employee data to determine

the eligibility. Once loaded the group of employees is static until the group is refreshed

or loaded again.

When a dynamic group is saved only the data conditions for the list are stored.

One dynamic group definition utility is provided:

n Payroll Data Conditions - The Payroll Data Condition is used to define a
selection group within a particular payroll. The definition uses a fixed set of
payroll data fields to determine membership in the group.

Fixed Groups

A fixed group is defined as a list of specific employees.

When the group is loaded the list is loaded from the storage area.

Fixed group definitions are determined by selecting employees from a list of eligible

employees. The list of employees may be from an existing group selection, all

employees, or employees in a particular payroll.
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Defining Employee Selection Groups

Employee Selection Groups may be defined in two ways:

1. Picking employees from a list of all employees known to a single payroll on
the system.

2. Selection of employees from a single payroll by setting conditions that payroll
data items for the employees must match.

The first type of selection group is a fixed list, thus a list must be maintained by the

user. A maximum of 1000 employees may be present in a fixed list. The last type of

selection group is a dynamic list, therefore each time the list is loaded the employee

data is compared to the conditions that define the selection. A dynamic list may

contain any number of employees.

The system provides for saving and loading any number of the selection group types.

Only one selection group may be active at a time.

Selection Group Restrictions

Auser IDmay be restricted to the use of a single selection group. The restriction and

nameof the selection group are set through theSystemAdministration functions.

The selection group restriction feature allows the SystemAdministrator to control

any user�s access to employees or to an arbitrary sub-set of employees on the system.

When a user ID is restricted to a particular selection group only the employees in that

selection group are visible to the user. When restricted, the user ID does not have

access to the functions that allow maintenance of the selection group definitions.

The user may remove employees from the selection group but this modification is

discarded the next time the user refreshes the selection group or logs off the system.
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Selection Group Processing

System functions that process more than one employee at a time will use the current

selection group (loaded and enabled) to determine the employee to process.

When a screen offers anext employee option, the next employee is always provided in

the order of the current selection group. The sort order of the current selection group

may be changed through the sort selection option.

When a report is generated by the report writer or any other reporting function the

employees included in the report are restricted to the current selection group (loaded

and enabled). This feature allows for easy production of sub-set reports.

Data Conditions for Selection Groups

A dynamic selection group definition is composed of three parts:

n Include Conditions - these conditions describe the data values that the
employee must have to be considered in the selection group.

n Exclusive Conditions - these conditions describe the data values that will result
in the employee being dropped from the selection group if the included
conditions are satisfied.

n Sort Order - these data fields are used to provide the initial sort order of the
selection group.
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Employee Group Management

When theGroupManagement option is selected the following submenuwill appear:

Selecting an Employee Group

This menu option will start up the Employee Group Selection Screen. This screen

provides the user with the facilities to define and maintain Employee Groups. The

following dialog box will appear.
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Once the Employee Group Selection dialog box appears choose the method of

selection by clicking on the SelectionMethod option in themenubar the following box

will appear.

After this has been done an employee selection listwill appear. The employees that are

contained in the list will depend on the method of selection chosen (see section on

selection lists below).

Select all the employees to be in the new selection group and press the OK button.

Next, select the Save Current Selection option from the File menu. The following

dialog box will appear:

Both the group code and the description must be entered into the fields to save the

group . Then select the OK button.
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When you are defining and maintaining Employee Group the following pull down

menu is available from the File option in the menu bar to view, clear, modify, and save

employee group. The following dialog box will appear:

View - to view the employee in the current group select the view current selection

from the File menu. The following box dialog box will appear:

Clear - to clear the current group select CLEAR CURRENT SELECTION from the

File menu. The employee group selection screen will now show no current groups.

Modify - to add or delete an employee from you current group select MODIFY

CURRENT SELECTION from the File menu.
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Employee Selection List

The employee selection list screen is presented when the selection of an employee is

required. The employees that appear in the list are subject to a number of conditions.

n Current Selection Group in Effect - When a selection group is loaded and
enabled only those employees in the selection group may appear in the list.

n Current Payroll Selected - When a payroll is selected only those employees that
are assigned to that payroll may appear in the list.

F When both a selection group is present and a payroll is selected only the employees
that are present in both the selection group and the payroll may appear in the list.

The order of the employees in the list is dependent on the search technique in effect for

the user.

n Search by name will present the employees in alphabetic sequence by surname
and given name.

n Search by employee number will present the employees in employee number
sequence.

n Search by badge will present the employees in badge number sequence

F The employees without a badge number will not appear in the list when the search by
badge technique is in effect.

The employees in the list are restricted by the value entered to search for an employee.

n Name Search will restrict the list to those employees whose last name
corresponds to the last name portion entered for the search.

n Employee Number will restrict the list to those employees whose employee
number is equal to or greater than the employee number entered for the search.

n Badge Number will restrict the list to those employees whose badge number
corresponds to the badge number portion entered for the search.
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Loading an Employee Group

The Load Employee Groupmenu option will display a list of the Employee Groups

available to the user. One of these groups may be selected for further operations. The

list will appear as follows:

By double clicking on the name of a group the user can load the group.

Inserting a new
group

If the INSERT button is selected a new dialog box will appear that allows the user to

define a new employee selection group. The dialog box appears as follows:

Removing a
group

Selecting the DELETE button will remove the highlighted employee group from the

list.
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Refresh Selection Group

The Refresh Selection Group option reloads the last selection group loaded. This

option is usedwhen the selection group has beenmodified and the userwants to reload

the group to eliminate any modifications.

To refresh a selection group the user simply selects the Refresh Selection Group

option in the Group Management sub menu under the File menu.

Modifying the Current Group

An existing employee selection group may be temporarily modified by adding or

deleting employees in the group.

When the initial group is a dynamic group the modifications will be retained until the

group is loaded again or refreshed.

The Modify Current Group option will bring up the Employee Selection Group

Modification dialog box. This option can be found on two different menus but the

results are the same.

The option is available in the File menu under the Group Management sub menu.

It is also available if the user selects the Select Employee Group option under the

Group Management sub menu, and in the Employee Group Selection dialog box the

user pulls down the File menu.
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The screen will appear as follows when either option is selected.

The dialog box contains a list of the employees in the currently selected employee

group.

To delete an employee, select that employee by clicking on it once with the mouse

then select the REMOVE button.

To insert an employee into the list select the ADD button, a new dialog box will appear

that asks for the name of the employee. Type in the last name of the employee and

select OK.

If the user does not know the last nameof the employee to be added then the user can:

n select theNEXT button to go to the following employee in the employee group
list, or

n select thePREVIOUSbutton to go to the previous employee on the employee
selection list, or

n select theList option from the File menu which will create a list of all the
employees in the current employee group, from which the user can select an
employee.
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Enabling an Employee Group

The Enable Employee Group option will turn on the current employee selection

group for processing. If the group is not enabled the system will not use the group for

processing.

When the selection group is enabled the system will limit access to the employees in

the selection group. This limit applies to both update functions and report functions.

TheEnable Employee Group option is available in two different menus and this can

be done either way. The user only needs to select the option to enable the current

selection group.

This option is available in the File menu under the Group Management sub menu.

It is also available if the user selects the Select Employee Group option under the

Group Management sub menu, and in the Employee Group Selection dialog box the

user pulls down the File menu.

Disabling an Employee Group

The Disable Employee Group option in the File menu will turn off the current

employee selection group. User ID's that are forced to use a selection group cannot

access this menu choice.

TheDisable Employee Group option is available in two different menus and this can

be done either way. The user only needs to select the option to disable the current

selection group.

The option is available in the File menu under the Group Management sub menu.

It is also available if the user selects the Select Employee Group option under the

Group Management sub menu, and in the Employee Group Selection dialog box the

user pulls down the File menu.
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Selecting/De-selecting a Payroll

The Select Payroll option from the File menu is used to select the payroll for

processing. Selecting this will result in a dialog box which displays a list of all the

available payrolls:

One of these payrolls must be selected for scheduling. The payroll is selected by

placing the cursor over the payroll and clicking the left-hand mouse button. The

payroll selected will appear in the main menu screen.

The De-select Payroll option from the File menu is used to de-select the currently

selected payroll. Selecting this will result in no payrolls being selected.
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SCHEDULE

The Schedule menu choice from the main menu bar is used to select functions that

prepare and process the GrandMaster Suite Schedule.

The Schedule menu appears as follows:

The options in the Schedule menu are used for creating rotation assignments (page

28) as well as scheduling leave time (page 44) and replacements (page 74) for those

employees on leave. This menu also allows the user to schedule positions (page 78)

and equipment to employees.

Schedules can bemade through the Generate Schedule (page 78), Scheduling a Date

Range (page 81) or Copying a Schedule Block (page 109) options.
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Rotation Assignments

The Rotation Assignment sub-menu appears as follows:

The Rotation Assignment option allows the user to create rotation assignments in

three different ways:

n by assigning an employee to a rotation pattern

n by assigning a rotation pattern to an employee

n make an employee specific rotation

The employee rotation assignments are used to generate a schedule for the employees.

The schedule generated may be modified through the detail scheduling option.
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Assign an Employee to a Rotation

TheAssignEmployee toRotation option is used to assign a list of employees to a user

defined rotation pattern.

The rotation pattern is defined using the Rotation Update choice in the Master Files

Menu selection in the Main Screen Menu.

F Rotation Patterns must be defined prior to any scheduling of employees.

When the user selects this option, the following dialog box will appear:

The screen contains the following data fields:

Field Description

Rotation This field is used to enter the code for the Rotation Pattern that will be used
for scheduling. The rotation description will be displayed to the right of the
code.

Rotation Employee

List

This list shows the employees assigned to the rotation selected. The list
includes from left to right: Start Date for the Rotation, End Date for the
Rotation, and the Start Day for the Rotation and Employee Name.

OK When the OK button is pressed the changes to the Rotation Employee assignments are

updated to the Schedule Data Tables. The Save option in the Filemenu gives the same

result as the OK button.

CANCEL When the CANCEL button is pressed the function exits without updating the Schedule

Data Tables. TheExit (or the ESCkey) option in the Filemenu gives the same result as

the CANCEL button.
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These functions are available from the File menu:

F8 (list) To display a list of the rotations previously defined, place the cursor in the rotation

field and press the F8 key, or the List option from the File menu.

Save To save any changes made in the employee rotation assignments to the Schedule Data

Tables select OK button, or the Save option from the File menu will give the same

result.

Esc (exit) The ESC key will exit the screen without saving any changes made in the assignments.

TheCANCELbutton, or theExitoption from theFilemenuwill give the same result.

These features are available in the Options menu:

Display Fields When the Display Fields function in the Options menu is selected the Employee

Assignment screen will automatically be displayed when one of the list entries is

highlighted. This allows for the employee assignment to be changed.

To activate the Display Fields simply select it from the Options menu so that a check

mark appears to the left. To turn it off select it again so that the checkmark is no longer

to the left of the option.

If the Display Fields function is turned off the user gets the same results by double

clicking on the appropriate list entry. The Display Fields function saves the user the

action of pressing the ENTER key.

F Selecting a blank list entry allows the insertion of a new employee assignment.

Scroll Table When the Scroll Table function in the Options menu is turned on, if there is a rotation

in the rotation field that any employeeswere assigned to previously, the listed datawill

be displayed automatically. If the Scroll Table is turned off the ENTER key must be

pressed to display the list.

To activate the Scroll Table function simply select it from the Options menu so that a

checkmark appears to the left. To turn it off, select it again so that the checkmark is no

longer to the left of the option.
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Selecting an Employee from the List

When the user selects one of the list entries the �Employee Assignments� screen will

appear as follows:

The screen requests the entry of the following data fields:

Field Description

Employee The Employee field is used to specify the employees name of
the rotation pattern. To the right of the name the badge number
will appear. If a payroll is selected the employee number will
appear instead of the badge number.

Start Date The Start Date field is the date that the employee is to start the
rotation pattern. This date and the start day field determine the
first shift worked by the employee.

Stop Date The Stop Date field is the date that the employee stops working
the rotation pattern.

Start Day The Start Day field is used to determine the employee's starting
day in the rotation pattern.

Position The Position field is used to specify the position the employee
will work.

Reason This field is used to specify the reason for the assignment and
may be used to indicate a reason outside of the normal
assignment such as relief work.

Area The Area field is used to specify the area code for the rotation
pattern.

Sub Area The Sub Area field is used to specify the subarea code for the
rotation pattern assignment.
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Field Description

Activity The Activity field is used to specify the activity code for the
rotation pattern assignment.

Sub Activity The Sub Activity field is used to specify the subactivity for the
rotation pattern assignment.

F8 (list) When the F8 key, or the List option from the File menu is pressed a list of the options

for the field where the cursor is placed will appear. This function will list start date,

stop date, or start day.

Save To update the Employee Rotation List press the F10 key, the OK button, or the Save

option from the Filemenu. The changeswill not be saved until you press theOKbutton

or the F10 key on the list screen.

Esc (exit) To exit the screen without saving any changes press the ESC key. The CANCEL button,

or the Exit option from the File menu will have the same effect.
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Assign a Rotation to an Employee

TheAssignRotation to Employee option is used to assign a list of rotation patterns to

an employee.

The Rotation Pattern is defined using the Rotation Table option in the Master Files

menu on the main menu bar.

F Rotation Patterns must be defined prior to any scheduling of employees.

When the user selects theAssign Rotation to Employee option, the following dialog

box will appear:

This screen contains the following data fields:

Field Description

Employee This field is used to enter the name of the Employee that will be
scheduled.

Rotation Pattern

Assigned.

This list shows the rotations assigned to the employee selected. The list
includes: Rotation Code, Rotation Name, Start Date for the Rotation,
and End Date for the Rotation.

OK When this button is pressed the changes to the Rotation Employee assignments are

updated to the Schedule Data Tables. The Save option in the Filemenu gives the same

result as the OK button.

CANCEL When this button is pressed the function exits without updating the Schedule Data

Tables. The Exit (or the ESC key) option in the File menu gives the same result as the

CANCEL button.
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These functions are available from the File menu:

F8 (list) When the cursor is placed in the employee field, pressing the F8 key, or theList option

in the File menu will display a list of the employees.

Save The OK button, or the Save option in the File menuwill save any changes made in the

assignments to the employee.

Esc (exit) The ESC key will exit the screen without saving any changes to the screen. The

CANCEL button, or the Exit option from the File menu will do the same function.

These functions are available from the Options menu:

Display Detail When the Display Detail function in the Options menu is selected the Rotation

Assignment screen will automatically be displayed when one of the list entries is

highlighted. This allows for the rotation assignment to be changed.

To activate the Display Detail simply select it from the Options menu so that a check

mark appears to the left. To turn it off select it again so that the checkmark is no longer

to the left of the option.

If the Display Detail function is turned off the user gets the same results by double

clicking on the appropriate list entry. The Display Detail function saves the user the

action of pressing the ENTER key.

F Selecting a blank list entry allows the insertion of a new rotation assignment.

Scroll Table When the Scroll Table function in the Options menu is turned on, if there is an

employee in the employee field that was assigned rotations previously, the listed data

will be displayed automatically. If the Scroll Table is turned off theENTERkeymust be

pressed to display the list.

To activate the Scroll Table function simply select it from the Options menu so that a

checkmark appears to the left. To turn it off, select it again so that the checkmark is no

longer to the left of the option.
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Selecting a Rotation from the List

When the user selects one of the list entries the Rotation Assignment screen will

appears as follows:

This screen requests the entry of the following data fields:

Field Description

Rotation This field is used to specify the rotation code for the rotation pattern.

Start Date This is the date that the employee is assigned to the rotation pattern.
This date and the starting day field determine the first shift worked by
the employee.

Stop Date This is the day that the employee stops working the rotation pattern.

Start Day This field is used to determine the employee's starting day in the
rotation pattern.

Position This field is used to specify the position the employee will work.

Reason This field is used to specify the reason for the assignment and may be
used to indicate a reason outside of the normal assignemnt such as
relief work.

Area This field is used to specify the area code for the rotation pattern.

Sub Area This field is used to specify the subarea code for the rotation pattern
assignment.

Activity This field is used to specify the activity code for the rotation pattern
assignment.

Sub Activity This field is used to specify the subactivity for the rotation pattern
assignment.
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F8 (list) When the F8 key, or the List option from the File menu is selected a list of the options

for the field where the cursor is placed will appear. This function will list start date,

stop date, start day, department, account, or sub account.

Save The OK button, or the Save option from the File menu will save any changes made in

the screen.

Esc (exit) The ESC key will exit the screen without saving any changes to the screen. The

CANCEL button, or the Exit option from the File menu will do the same function.
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Employee Specific Rotations

The Employee Specific Rotation option is used to create a rotation and shift pattern

that is unique for a specific employee. The Employee Specific Rotation allows up to

five shifts in eachwork daywith a separate start and stop time assigned to each shift.

F You can have a maximum of 100 days per specific employee rotation.

When this option is selected, the following dialog box will appear:

This screen provides the following data entry fields:

Field Description

Rotation This field is used to specify a rotation code for the rotation pattern. The
rotation pattern codes must be unique for an employee. The same code may
be used for different employees.

Description This field is used for a description of the rotation pattern.

Number of Days This field is used to set the number of days for the rotation pattern. There is a
maximum of 100 days possible.

Starting Date This field is used for the starting date of the rotation pattern.

Ending Date This field is used for the ending date of the rotation pattern.
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Field Description

Shift List This list contains an entry for each day of the rotation pattern. Selection of a
particular day allows the entry of the shifts to be worked on that day.
The Shift List contains the following information from left to right: day
number, day of the week, and up to five shift types.

OK This button is used to update the rotation pattern to the schedule data tables.

CANCEL This button is used to exit from the functionwithout updating the schedule data tables.

The functions available from the File menu are:

Next Employee The Next Employee option in the File menu will bring up the next employee in the

employee list. This key only moves to the next employee if a valid rotation has been

entered for the current employee.

F8 (list) The F8 key, or the List option from the File menu will list the available data for either

the employee or rotation fields depending in which field the cursor is placed.

When the user calls up a list of the rotations for the employee the following dialog box

will appear:

This dialog box allows the user to select a rotation for the employee by double clicking

on the list entry or moving the selection bar to the desired entry and pressing the OK

button.

The CANCEL button or theExit option from the File menu will exit the screen without

making a selection.
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Delete The Delete option in the File menu will delete the current rotation for the current

employee only.

Save The Save option in the File menu, or the OK button will save any changes made to the

screen.

Esc (exit) The ESC key, or theExit option from the File menu will exit the screen without saving

any changes. The CANCEL button will also exit without saving any changes.

The functions available from the Options menu are:

Display Fields When the Display Fields function in the Options menu is selected the Shift Selections

screenwill automatically be displayedwhen one of the list entries is highlighted. This

allows for the shifts to be changed.

To activate the Display Fields simply select it from the Options menu so that a check

mark appears to the left. To turn it off select it again so that the checkmark is no longer

to the left of the option.

If the Display Fields function is turned off the user gets the same results by double

clicking on the appropriate list entry. The Display Fields function saves the user the

action of pressing the ENTER key.
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Selecting a Shift Assignment from the List

When a particular day in the Shift List is selected a new dialog box will appear which

allows the user to enter the shifts that will be worked by an employee on a particular

work day.

The dialog box appears as follows:

Up to five (5) shifts may be specified for a single work day. Each shift has a start and

stop time. When the base shift used for the schedule has unpaid breaks set, these

breaks will be deducted from the total working hours only if the breaks fall within the

start and stop times set.

The dialog box contains the following data entry fields for each shift segment:

Field Description

Shift Code This field contains the code for the shift to be worked. The shift name will
appear, for display only, to the right when a shift code has been selected.

Premium The premium codes (up to 10) are entered into this field.

Position This field contains the position for the shift segment.

Start This field is used to enter the starting time for the shift segment.

Stop The stopping time for the shift segment is entered into this field.
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OK This button is used to temporarily save the shift segments in the current shift list to the

employee specific rotation screen.

A permanent save is done when the OK button is selected on the employee specific

rotation screen.

The shift selections screen will not be closed by this action. It can only be closed by

selecting the close option from the system menu in the upper left hand corner.

Esc (exit) The ESC key, the CANCEL button, or theExit option from the File menu are used to go

back to the employee specific rotation screen without changing the current shift list.

The shift selections screen will not be closed by this action. It can only be closed by

selecting the close option from the system menu in the upper left hand corner.

CLEAR This button is used to clear all the fields on the screen.

F8 (list) The F8 key will list either the shift code or the position depending in which field the

cursor is placed.
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Generating a Schedule

The generation of schedules from rotation patterns is done through the Generate

Schedulemenu choice on theRotationAssignment submenu in the Schedulemenu of

the Schedule Module main menu screen.

The Generate Schedule option is used to create Employee Schedule Items from the

RotationAssignments for the employees. This option scans theRotationAssignments

in the Schedule Tables and creates individual Employee Schedule Items.

This option requires the input of a start date and end date to control the generation

process. Schedule items are generated only for those dates in the date range specified.

When a schedule has been previously generated for dates in the range, the option will

overwrite these items with the new schedule unless the schedule items have been

processed through the Time Keeping module.

After the schedule items have been generated the schedule generation option will use

the leave schedule entries to overlay the work time segments with the scheduled leave

time.

F Schedule Items for an employee will not be created when an individual item for a
particular date already appears in the Schedule Item table.

F The employees included in the schedule generation process are governed by the
selection group currently in force.
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When theGenerate Schedule option is chosen the following dialog boxwill appear:

The Generate Schedule screen contains the following data entry fields:

Field Description

Starting Date This field contains the start date for the schedule generation. The date is
automatically set to the day following the last generated schedule.

Ending Date This field contains the ending date for the schedule generation. The date is
automatically set to starting plus the number of days in the Control Data
Update entry field of Days to Schedule.

OK The OK button is pressed to generate the schedule for the date range entered in the

Starting Date and Ending Date fields.

CANCEL The CANCEL button is pressed to exit from the function without generating any

schedule items.
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Leave Time

The following sub menu includes the options available under Leave Time:

The Leave Time option supports five major divisions of leave time:

n vacation

n sick leave

n time off in lieu

n training

n other leave

n all leave

Eachmajor type of leave time has an associated set of reason codes. The reason codes

are used to describe the purpose for the leave time. The system user may define any

number of reason codes for each type of leave.

Each major type of leave may have an associated payroll earning code that is used to

allocate the time granted for the leave. This earning code is normally associatedwith a

payroll accumulator that is used to track the employee's entitlement for the leave time.

When leave time is scheduled for an employee that is assigned to a standard shift

rotation, the standard shift assignments in the date range scheduled for leave for that

employee are replaced by the system defined shift code for the leave type.
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Vacation Leave

When the Vacation option from the Leave Time sub menu is selected the following

screen will appear:

The Schedule - Vacation Time dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Leave

List

The list contains all the vacation leaves that have been scheduled within the
date range. From left to right the list contains: starting date, ending date,
starting time, ending time, and the employee.

Set Date Range The Set Date Range option from the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.

Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.
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Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.

Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

Vacation Leave Entry

When a vacation leave item is inserted or updated the following dialog box will

appear:

The following table contains descriptions of the fields within the Vacation Schedule

Entry dialog box:

Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.
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Field Description

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Type This field is used to enter the user defined type code. A list of the defined
codes can be generated by selecting the F8 key. The description of the type
code will appear to the right of this field after a type has been selected.

Days This field contains the days of the week that the leave entry may affect. This
field is ignored for a one day date range.

Generate The Generate check box turns on the segment generation option.

Holidays The Holidays check box determines if the leave entry generation option is in
effect for holidays registered in the system calendar.

Overlay The Overlay check box turns on the overlay segment processing option.

Replace The Replace check box turns on the replace segment processing option.

Weekends The Weekends check box determines if the leave entry generation option is in
effect for weekend days.

Extend The Extend check box turns on the extend segment processing option.

Overlap The Overlap check box turns on the overlap processing option.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8key, or theList option in the Filemenuwill bring up a list of available options

relating to the field inwhich the cursor is placed. The only fieldswhichwill contain a

list are: replacement and type.

Save TheOK button, or theSave option in the Filemenuwill save any changesmade in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.
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Sick Leave

When the Sick Leave option from the Leave Time sub menu is selected the following

screen will appear:

The Schedule - Sick Time dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Items

List

The list contains sick times that have been scheduled within the date range.
From left to right the list contains: starting date, ending date, starting time,
ending time, and the employee.

Set Date Range The Set Date Range option from the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.
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Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.

Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.

Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

Sick Leave Entry

When a sick leave item is inserted or updated the following dialog box will appear:

The following table contains descriptions of the fields within the Sick Schedule Entry

dialog box:

Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.
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Field Description

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Type This field is used to enter the user defined type code. A list of the defined
codes can be generated by selecting the F8 key. The description of the type
code will appear to the right of this field after a type has been selected.

Illness This field is used to enter the user defined illness code. A list of the defined
codes can be generated by selecting the F8 key. The description of the illness
code will appear to the right of this field after an illness has been selected.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8 key, or the List option in the File menu will bring up a list of available options

relating to the field in which the cursor is placed. The only fields which will contain

lists are: replacement, type and illness.

Save The OK button, or the Save option in the File menu will save any changes made in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.
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Time Off in Lieu

When the Time Off in Lieu option from the Leave Time sub menu is selected the

following screen will appear:

The Schedule - In Lieu Time dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Items

List

The list contains in lieu times that have been scheduled within the date range.
From left to right the list contains: starting date, ending date, starting time,
ending time, and the employee.

Set Date Range The Set Date Range option from the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.
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Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.

Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.

Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

Time Off in Lieu Leave Entry

When a time off in lieu leave item is inserted or updated the following dialog box will

appear:

The following table contains descriptions of the fields within the Time Off in Lieu

Schedule Entry dialog box:
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Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Reason This field is a validated code entry from a reason table for the leave type.

Days This field contains the days of the week that the leave entry may affect. This
field is ignored for a one day date range.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8key, or theList option in the Filemenuwill bring up a list of available options

relating to the field inwhich the cursor is placed. The only fieldswhichwill contain a

list are: replacement and reason.

Save TheOKbutton, or theSave option in the Filemenuwill save any changesmade in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.
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Training

When the Training option from the Leave Time sub menu is selected the following

screen will appear:

The Schedule - Training Time dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Items

List

The list contains training times that have been scheduled within the date range.
From left to right the list contains: starting date, ending date, starting time,
ending time, and the employee.

Set Date Range The Set Date Range option from the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.

Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.
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Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.

Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

Training Leave Entry

When a training leave item is inserted or updated the following dialog boxwill appear:

The following table contains descriptions of the fields within the Training Schedule

Entry dialog box:

Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.

Can-Pay Computer Software 55

SCHEDULE - 3

S
C
H
E
D
U
L
E



Field Description

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Course This field is used to enter the user defined course code. A list of the defined
codes can be generated by selecting the F8 key. The description of the course
code will appear to the right of this field after a course has been selected.

Days This field contains the days of the week that the leave entry may affect. This
field is ignored for a one day date range.

Generate The Generate check box turns on the segment generation option.

Holidays The Holidays check box determines if the leave entry generation option is in
effect for holidays registered in the system calendar.

Overlay The Overlay check box turns on the overlay segment processing option.

Replace The Replace check box turns on the replace segment processing option.

Weekends The Weekends check box determines if the leave entry generation option is in
effect for weekend days.

Extend The Extend check box turns on the extend segment processing option.

Overlap The Overlap check box turns on the overlap processing option.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8 key, or the List option in the File menu will bring up a list of available options

relating to the field in which the cursor is placed. The only fields which will contain a

list are: replacement and course.

Save The OK button, or the Save option in the File menu will save any changes made in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.
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Other Leave

When the Other Leave option from the Leave Time sub menu is selected the

following screen will appear:

The Schedule - Other Leave Time dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Items

List

The list contains other leaves that have been scheduled within the date range.
From left to right the list contains: starting date, ending date, starting time,
ending time, and the employee.

Set Date Range TheSetDateRange option from the Filemenuwill allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.

Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.
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Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.

Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

Other Leave Entry

When an other leave item is inserted or updated the following dialog boxwill appear:

The following table contains descriptions of the fields within the Other Leave

Schedule Entry dialog box:

Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.
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Field Description

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Reason This field is used to enter the user defined reason code. A list of the defined
codes can be generated by selecting the F8 key. The description of the reason
code will appear to the right of this field after a reason has been selected.

Days This field contains the days of the week that the leave entry may affect. This
field is ignored for a one day date range.

Generate The Generate check box turns on the segment generation option.

Holidays The Holidays check box determines if the leave entry generation option is in
effect for holidays registered in the system calendar.

Overlay The Overlay check box turns on the overlay segment processing option.

Replace The Replace check box turns on the replace segment processing option.

Weekends The Weekends check box determines if the leave entry generation option is in
effect for weekend days.

Extend The Extend check box turns on the extend segment processing option.

Overlap The Overlap check box turns on the overlap processing option.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8key, or theList option in the Filemenuwill bring up a list of available options

relating to the field inwhich the cursor is placed. The only fieldswhichwill contain a

list are: replacement and reason.

Save The OKbutton, or theSave option in the Filemenuwill save any changesmade in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.
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All Leave Schedule

When the All Leave Schedule option from the Leave Time sub menu is selected the

following dialog box will appear:

The GrandMaster Leave Schedule dialog box contains the following data fields:

Field Description

From The starting date of the date range is displayed in this field.

To The ending date of the date range is displayed in this field.

Schedule Items

List

The list contains all types of leaves that have been scheduled within the date
range. From left to right the list contains: type of leave, starting date, ending
date, starting time, ending time, and the employee.

Set Date Range The Set Date Range option from the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option from the File menu is the option used to

add a new item to the list.

Additional The ADDITIONAL button, or theAdditional for Employee option from the File menu

will allow the user to enter another entry for the same employee selected by the

selection bar. This saves the user the step of selecting the employee again.

Update The UPDATE button, or the Update Entry option from the File menu will call up the

item selected by the selection bar so that changes can be made to the current

information.

Delete TheDELETEbutton, or theDeleteEntry option from the Filemenuwill delete the item

of the list which is selected by the selection bar.
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Esc (exit) TheESCkey,EXITbutton, or theExitoption from theFilemenuwill exit the function.

All Leave Entry

When a new all leave item is inserted the following dialog box will appear:

The following table contains descriptions of the fields within the All Leave Schedule

Entry dialog box:

Field Description

Employee This field contains the employee currently being scheduled for leave. This
field is for display only.

Replacement The employee that will replace the employee on leave is entered into this data
field.

Start Date This field contains the starting date for the leave entry date range.

End Date This field contains the ending date for the leave entry date range. When this
field is not entered it is assumed to be identical to the start date.

Start Time The starting time for the leave entry time range is entered into this field. When
'overlay processing only' is in effect this field may be zero.
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Field Description

Stop Time The stopping time for the leave entry time range is entered into this field.
When the 'overlay processing only' is in effect this field may be zero.

Type The type of leave is selected for this field. The field contains a pull down list
from which to select the type of leave to be entered.

Reason This field is used to enter the user defined reason code. A list of the defined
codes can be generated by selecting the F8 key. The description of the reason
code will appear to the right of this field after a reason has been selected.

Description This field is a free form multi-line text field that may be used for additional
descriptive information.

F8 (list) The F8 key, or the List option in the File menu will bring up a list of available options

relating to the field in which the cursor is placed. The only fields which will contain a

list are: replacement and reason.

Save The OK button, or the Save option in the File menu will save any changes made in the

dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

dialog box without saving any changes.

In the Leave Schedule Entry dialog box only the information common to every type of

leave can be entered. To enter any data that is unique to the type of leave, i.e., the

'course' field is unique to training leave, once the leave has been inserted the user must

then select the new item from the Schedule Items List (in the GrandMaster Leave

Schedule screen) and select the UPDATE button to bring up the leave entry screen

specific for the type.

When an existing all leave item is updated the dialog box that will appear depends on

the leave type of the item. See the appropriate section of leave type in this chapter for

information about the dialog box, e.g., if the leave type of the item selected is training,

see the section on training leave.
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Leave Time Processing

WhenLeaveTime is entered for an employee that is scheduled, the systemwill update

the work time segments to reflect the Leave Time Entry. Leave Time Entries provide

several processing options. These options control the way that the Leave Time Entry

segments substitute for existing work segments.

n Generate- This option causes the Leave Time Entry to generate new Leave
segments on days that do not have an existing work segment. The new segment
uses the Leave Entry start and stop times.

n Overlay - This option causes the Leave Time Entry to overlay only existing
work time segments using the work segment start and stop times.

n Replace- This option causes the Leave Time Entry to replace work segments
with a leave segment that uses the Leave Entry start and stop times.

n Extend - This option causes the Leave Time Entry to extend existing work
segments to the Leave Entry start and stop times. Overlapping time periods are
overlaid with the Leave Entry.

n Overlap - This option causes the time entry generation to insert new
segments that overlap existing work segments. The existing work segment is
not affected by the new segment.

The Generate option may be combined with any one of the other four options.

The Overlay, Replace, Overlap, and Extend options are mutually exclusive

The default for Leave Processing is the Overlay option.
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F For the standard shift assignments to be replaced by the system defined shift code it is
required that no start and stop times are assigned for the leave schedule.

Example: Fred Johns works the following rotation:

Jan 1 2 3 4 5 6 7 8 9 10 11

DAY DAY DAY NIGHT NIGHT NIGHT EVENIN
G

When vacation is scheduled for Jan. 2 through Jan. 7 inclusive, the six days
vacation time span would have an affect on only the four standard work days in the
date range requested for vacation therefore the shift assignments would become:

Jan 1 2 3 4 5 6 7 8 9 10 11

DAY $VAC $VAC $VAC $VAC NIGHT EVENIN
G

All leave types may have a date range and a start and stop time. When the date range

contains more than one day the same start and stop time are assigned for each day.

Example: Time off in lieu - July 4 through July 7
Start Time - 13:00 Stop Time - 17:00
would result in 4 hours time off allocated for each of the days in the range
for a total of 16 hours.

Leave scheduled with a start and stop time will partially replace work shift

assignments. When a work shift assignment is not present for a date in the range no

leave time assignment is made for that day.

When leave time is scheduled for an employeewhodoes notwork a scheduled position

the payroll system uses the scheduled date range to assign vacation days in place the

employee's standard work days.

Example: Sharon Silver works Monday thru Friday each week except
Statutory holidays.
Vacation days - June 26, 1995 thru July 14, 1995
Statutory holiday - July 3, 1995
This results in 14 days vacation taken and 1 statutory holiday.

F Overlay Only
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If the Leave Time Entry specifies a date range, the same starting time will be used for

each day in the date range.

ALeaveTimeEntrymayoptionally overlay existingworkwith leave time segments.

Example:

Original Work
Segments

1995/05/04 8:00 16:00

1995/05/05 8:00 16:00

1995/05/06 8:00 16:00

1995/05/07 8:00 16:00

In Lieu Entry 1995/05/04 to
1995/05/06

12:00 18:00

Will result in:

Work 1995/05/04 8:00 12:00

In Lieu 1995/05/04 12:00 18:00

Work 1995/05/05 8:00 12:00

In Lieu 1995/05/05 12:00 18:00

Work 1995/05/06 8:00 12:00

In Lieu 1995/05/06 12:00 18:00

Work 1995/05/07 8:00 16:00
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F Generate and Overlay

A Sick Time Entry may optionally generate new sick time segments for days without

existing work segments.

When the Leave Time Entry is a portion of a work time segment will be split into two

or three segments to reflect the Leave Time Entry. If the Leave Time Entry is

subsequently modified the work segment split will be restored to the original.

Example:

Original:

Original Work Segment 1995/05/04 8:00 16:00

Sick Leave Entry with
Generate Option

1995/05/05 12:00 14:00

Will result in:

Work Segment 1995/05/04 8:00 12:00

Sick Segment 1995/05/04 12:00 14:00

Work Segment 1995/05/04 14:00 16:00

Sick Segment 1995/05/05 12:00 14:00
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F Overlay Only - No Ending Time

When an InLieuTimeEntry ismadewith only a starting time specified the systemwill

replace all work time segments after that timewith Leave Time segments. If the Leave

Time Entry specifies a date range, the same starting time will be used for each day in

the date range.

Example:

Original Work
Segments

1995/05/04 8:00 16:00

1995/05/05 8:00 16:00

1995/05/06 8:00 16:00

In Lieu Entry 1995/05/04 to
1995/05/06

12:00 16:00

Will result in:

Work 1995/05/04 8:00 12:00

In Lieu 1995/05/04 12:00 16:00

Work 1995/05/05 8:00 12:00

In Lieu 1995/05/05 12:00 16:00

Work 1995/05/06 8:00 12:00

In Lieu 1995/05/06 12:00

Can-Pay Computer Software 67

SCHEDULE - 3

S
C
H
E
D
U
L
E



F Overlay Only - No Starting Time

When an In Lieu Time Entry is made with only an ending time specified the system

will replace all work time segments before that timewith Leave Time segments. If the

Leave Time Entry specifies a date range, the same ending time will be used for each

day in the date range.

Example:

Original Work
Segments

1995/05/04 8:00 16:00

1995/05/05 8:00 16:00

1995/05/06 8:00 16:00

In Lieu Entry 1995/05/04 to
1995/05/06

12:00

Will result in:

In Lieu 1995/05/04 8:00 12:00

Work 1995/05/04 12:00 16:00

In Lieu 1995/05/05 8:00 12:00

Work 1995/05/05 12:00 16:00

In Lieu 1995/05/06 8:00 12:00

Work 1995/05/06 12:00 16:00
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F Replace Only

A Training Entry may optionally replace existing work segments with a Training

segment. The Leave Time segment will use the start and stop time for Leave Time

Entry only, rather than overlaying a portion of the work time segment.

Example:

Original Work
Segments

1995/05/15 8:00 16:00

1995/05/17 8:00 16:00

Training Entry 1995/05/14 to
1995/05/18

9:00 15:00

Will result in:

Training 1995/05/15 8:00 15:00

1995/05/17 9:00 15:00

F Generate and Replace

A Leave Time Entry may optionally generate new training segments for days

without existing work segments and replace existing work segments entries. The

Leave Time segment will use the start and stop time for Leave Time Entry only,

rather than overlaying a portion of the work time segment.

Example:

Original Work
Segments

1995/05/08 8:00 16:00

1995/05/10 8:00 16:00

Training Entry with
Generate Option

1995/05/08 to
1995/05/11

8:30 15:00

Will result in:

Training 1995/05/08 8:30 15:00

1995/05/09 8:30 15:00

1995/05/10 8:30 15:00

1995/05/11 8:30 15:00
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F Extend Only

A Leave Time Entry may optionally extend existing work time segments. The work

time segments will be extended to the Leave Time entry start and stop time with any

overlap being overlaid with the Leave Time.

Example:

Original Work
Segments

1995/05/23 8:30 16:30

1995/05/25 8:30 16:30

Leave Time Entry 1995/05/23 to
1995/05/26

13:00 17:30

This will result in:

Work Segment 1995/05/23 8:30 13:00

Leave Segment 1995/05/23 13:00 17:30

Work Segment 1995/05/25 8:30 13:00

Leave Segment 1995/05/25 13:00 17:30
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F Generate and Extend

A Leave Time Entry may optionally generate new Leave Time segments for days

without existing work segments and extend existing work time segments. The new

time segments will use the Leave Entry start and end time. The existing work

segments will be extended to the Leave Time entry start and end timewith any overlap

being overlaid with the Leave Time.

Example:

Original Work
Segments

1995/05/18 7:30 15:30

1995/05/19 11:00 14:00

1995/05/20 12:00 20:00

Leave Time Entry with
Generate Option

1995/05/18 to
1995/05/21

8:30 15:00

The result will be:

Work Segment 1995/05/18 7:30 8:30

Leave Segment 1995/05/18 8:30 15:00

Work Segment 1995/05/18 15:00 15:30

Leave Segment 1995/05/19 8:30 15:00

Leave Segment 1995/05/20 8:30 15:00

Work Segment 1995/05/20 15:00 20:00

Leave Segment 1995/05/21 8:30 15:00
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F Overlap Only

A Leave Time Entry may optionally insert overlap time segments for days with

existing work time segments.

The existing work segments will not be affected by the new segments. The new

segments will use the Leave Entry start and end time.

Example:

Original Work
Segments

1995/05/21 8:00 16:00

1995/05/23 8:00 16:00

Leave Entry 1995/05/20 to
1995/05/24

11:00 14:00

This will result in:

Work Segment 1995/05/21 8:00 16:00

Leave Segment 1995/05/21 11:00 14:00

Work Segment 1995/05/23 8:00 16:00

Leave Segment 1995/05/23 11:00 14:00
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F Generate and Overlap

A Leave Time Entry may optionally generate new leave time segments for days

without existing work segments and insert overlap time segments for days with

existing work segments.

The existing work segments will not be affected by the new segments. The new

segments will use the Leave Entry start and end time.

Example:

Original Work
Segment

1995/05/21 8:00 16:00

1995/05/23 8:00 16:00

Leave Segment with
Generate Option

1995/05/20 to
1995/05/23

11:00 14:00

This will result in:

Leave Segment 1995/05/20 11:00 14:00

Work Segment 1995/05/21 8:00 16:00

Leave Segment 1995/05/21 11:00 14:00

Leave Segment 1995/05/22 11:00 14:00

Work Segment 1995/05/23 8:00 16:00

Leave Segment 1995/05/23 11:00 14:00
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Replacement Schedule

When a leave schedule entry updates the employee work time segments the Schedule

Module may present the time segment replaced by the leave time as a segment

requiring a replacement or relief employee.

The Schedule Module provides a facility for presenting the work time segments

requiring replacement or relief workers.

The schedule relief work function will present the work time segments that were

substituted by leave time segments and allow the user to choose replacement

employees for the time segments.

The schedule relief work function allows the input of a date range to be scanned for

work segments requiring replacements and the type of leave to find replacement

employees.

When the Schedule Replacement option is chosen the following dialog box will

appear:

After the data is entered for the date range and leave types, the Schedule Items List

shows the work segments requiring replacements.

The functions are restricted to showing work segments that were assigned to

employees belonging to the current employee group.
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The dialog box contains the following data entry fields:

Field Description

Start Date This field is used to enter the starting date of a date range to scan for work
segments requiring replacement employees. Default value is the current
system date.

End Date This field is used to enter the ending date of a date range to scan for work
segments requiring replacement employees. Default value is the starting date
plus seven days.

Leave Types

vacation, sick,

training,

in lieu, other

This set of check boxes is used to indicate the types of leave to find
replacement employees for.

Ignored This check box controls the display of schedule items marked as ignored.
When the box is checked items marked ignored are displayed. The letter �I�
precedes the item in the list box.

Replaced This check box controls the display of schedule items that have replacement
entries. When the box is checked items with replacement items are displayed.
The letter �R� precedes the item in the list box.

Replacements This check box is used to switch the display to the replacement work time
segments rather than the time segments that require replacement. The refresh
button must be pressed after the check box is changed to alter the display
contents.

Set Date Range The Set Date Range option in the File menu will allow the user to change the date

range for replacing employees on leave.

Refresh When the leave types check boxes are changed the user must click on the REFRESH

button, or theRefreshScreen option in the Filemenu to view the items requested.

Select
Replacement

The user may select an employee to fill each of the required work segments. Place

the selection bar on the desired item in the Schedule Items List and either select the

SELECT REPLACEMENT button, or the Replace Entry option in the File menu.

Ignore Awork segmentmay also be flagged as not requiring a replacement. This will prevent

the work segment from appearing in a later scan of the date range the work segment

appears in. The function may optionally show both flagged and regular segments.

Place the selection bar on the desired item in the Schedule Items List and either select

the IGNORE button, or the Ignore Entry option from the File menu.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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The screen that requests the employee for the replacement shift requires the same data

that is requested for work segment scheduling.

The screen appears as follows:

The following data fields are available for input:

Field Description

Employee This field is used to enter the name of the replacement employee. After an
employee is selected the badge number will appear to the right of the name.
However, if a payroll is select the employee number will appear in place of
the badge number. The number that appears is for display only.

Date This field displays the date of the work segment. The date may not be
changed.

Shift This field displays the original shift of the work segment that requires a
replacement employee.

Premium This field displays the premium codes assigned to the original work
segment.

Start Time This field displays the starting time of the work segment that requires a
replacement employee.

Stop Time This field displays the stopping time of the work segment that requires a
replacement employee.

Hours The hours field contains the number of hours calculated by stop time minus
the start time. This field is for display only.
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Field Description

Reason This field displays the reason code assigned to the original work segment.

Position This field displays the position code assigned to the original work segment.

Area This field displays the area code assigned to the original work segment.

Sub Area This field displays the sub area code assigned to the original work segment.

Activity This field displays the activity code assigned to the original work segment.

Sub Activity This field displays the sub activity code assigned to the original work
segment.

Department This field displays the department code assigned to the original work
segment.

Account This field displays the account code assigned to the original work segment.

Sub Account This field displays the sub account code assigned to the original work
segment.

Next Employee The NEXT button, or the Next Employee option in the File menu will advance to the

next employee in the current group.

Previous
Employee

The PREVIOUSbutton, or thePrevious Employee option in the Filemenuwill return

to the previous employee in the current group.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of available

options relating to the field in which the cursor is placed. The fields which will

contain a list are: employee, shift, reason, position, area, sub area, activity, and sub

activity.

F10 (save) The F10 key, theOK button, or theSave option in the Filemenuwill save any changes

made in the dialog box.

Delete The DELETE button, or the Delete option in the File menu is used to delete the

replacement work segment. The original work segment requiring a replacement is

reset and becomes an outstanding segment requiring a replacement.

Esc (exit) TheESCkey, theCANCELbutton, or theExit option in the Filemenuwill exit the dialog

box without saving any changes.
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Department Positions

The SCHEDULE MODULE provides a facility for scheduling employees for

positions defined by a structure by the ORGANIZATION CHART MODULE.

This function scans an organization chart structure searching for positions marked as

�able to schedule�. The positions found are displayed for a one week period. The

facility allows the user to move back and forward in time by one week periods.

When employees that have been scheduled are not in the current group, the facilitywill

not present the data for these employees except as part of the total hours scheduled for

the position.

An organization chart structure may contain both �able to schedule� and �not able to

schedule� positions. Only those positions marked as �able to schedule� will appear in

the schedule by department function.

Defining an Organization Chart Structure

The organization chart definition facility allows the user to define a tree structure for a

department. The root of the tree must be an organization chart object. The �able to

schedule� positions must be nodes that descend from the root object.
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Example: The following is an example of an organization chart structure that may
be used for scheduling:

Root Object

Group = $Department

Code = Ward 1

Descendants

Node 1 Position = Nurse

Days of Week = 23456

Start Time = 08:00

End Time = 24:00

Hours/Day = 48.0

Node 2 Position = Nurse

Days of Week = 17

Start Time = 08:00

End Time = 16:00

Hours/Day = 16.0

Node 3 Position = Aide

Days of Week = 1234567

Start Time = 08:00

End Time = 24:00

Hours/Day = 32.0

The structure defines a department containing three “able to schedule” positions.

The first node requires employees that can fill the requirements for the position
nurse.  The position must be filled Monday through Friday and requires 48.0 person
hours per day between 8:00 am and midnight.

The person hour requirement would translate to 6 people working 8 hour shifts
each day the position is required.
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The second node requires employees that can fill the requirements for the position
nurse.  The position must be filled Saturday and Sunday and requires 16.0 person
hours per day between 8:00 am and 4:00 pm.

The person hour requirement would translate to 2 people working 8 hour shifts
each day the position is required.

The third node requires employees that can fill the requirements for the position
aide.  The position must be filled Sunday through Saturday and requires 32.0
person hours per day between 8:00 am and midnight.

The person hour requirement would translate to 4 people working 8 hour shifts
each day the position is required.

The translation of hours/day to the number of persons assumes that the hours/day
requirement is evenly distributed between the start time and the end time specified
for the node.  If the hours/day requirement is not evenly distributed additional
nodes must be defined.

The structure could be defined such that a node exists for each employee shift that
must be filled.

Node Position Requirements

When a node is defined the requirements for the position are always required for

selecting employees to schedule for the node. When the requirements for the position

are changed those changes will affect the selections for the node.

The node may have additional requirements that are unique to the node. These

requirements are used in addition to the position requirements when selecting

employees to schedule for the node.
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Automated Scheduling

When the user selects the Automated Scheduling sub menu from the Schedule menu

the following screen will appear:

The following options are available to the user:

n Generate Shifts

n Assign Employees to Shifts

n Update Department Shifts
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Generate Shifts

The Generate shifts function uses a man hour requirements data structure from the

resource planning module to create work shifts. This structure is identified by the

combination of the group and code values.

The function scans the position andman hour requirements in the structure and creates

work shifts to satisfy those requirements.

When the user selects the Generate Shifts option from the Automated Scheduling

sub-menu the following screen will appear:

The dialog box contains the following data fields:

Field Description

Group This value is used to identify the resource planning group.

Code This value is used to identify the resource planning code.
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Assign Employee to Shifts

When the user selects the Assign Employee to Shifts option from the Automated

Scheduling sub-menu the following screen will appear:

The dialog box contains the following data fields:

Field Description

Starting Block

Date

This field contains the starting date for the shift.

Ending Block

Date

This field obtains the ending date for the shift.
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Update Department Shifts

The update department shifts function allows the user to extract and update the work

shifts that have been generated for a particular resource planning man hour

requirements data structure.

The function will display the work shifts for a single day at a time.

When the user selects the Update Department Shifts option from the Automated

Scheduling sub-menu the following screen will appear:

The dialog box contains the following data fields:

Field Description

Group The value used to identify the resource planning group.

Code The value used to identify the resource planning code.

Date This field contains the date for the work shifts to update.
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Display Available Employees

When the user selectsDisplay Available Employees option from the Schedule menu

the following screen will appear:

The following table gives a description of the screen:

Field Description

Starting This field contains the starting date of the employee.

Ending This field contains the enind date of the employee.

Name This field contains the employees name.

Number This field contains the employees badge number.
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Weekly Employee Schedule

The Weekly Schedule function for the current employee group is for a one week

period. The function allows the user to mark employees as sick or leave and select a

replacement for the shift.

The function displays a screen that allows the entry of the starting date for the week to

display. The screen will appear as follows:

The �Schedule a Date Range� dialog box only requires the user to enter the desired

starting date for the date range. The date must be entered in ending format.

WORK TIME The WORK SCHEDULE button, or the Schedule Work option from the File menu

extracts and displays only the shift assignments that are actual work time.

ALL TIME The ALL TIME button, or the Full Schedule option from the File menu extracts and

displays all time segments including work time, vacation, sick time, etc.

Esc (exit) The ESC key, the EXIT button, or the Exit option from the File menu will exit the

function.
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Schedule Notebook

The weeks schedule is displayed in notebook format. Each page of the notebook

contains a single days schedule. The notebook will appear as follows:

Each notebook page contains the following data fields:

Field Description

Start Date This field contains the starting date of the week. This field is for display only.

End Date This field contains the ending date of the week. This field is for display only.

List The list shows (from left to right) the shift code, start time, stop time, gross
hours, employee name, and position code for each time segment of the day.

Current Date The date of the day currently on the screen will be displayed in the lower right
hand corner of the screen.
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Update The UPDATE button allows the user to update all time segments for the employee that has a time

segment selected (selection bar highlighting the schedule entry).

The dialog box will appear as follows:

Change the appropriate information and select the OK button.

Insert The INSERT button allows the user to insert a new employee in the days schedule. A

dialog box similar to the Employee Schedule Item Update, seen above, will appear.

Fill in the data fields and select the OK button.

Delete TheDELETEbutton is used to delete the selected schedule item from the days schedule.
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Swap The SWAP button allows the user to swap the shifts between two existing scheduled

shifts. There must be at least two existing shifts in order to swap.

To perform a swap do the following:

1. Move the selection bar to one of the shifts to be swapped and pressing the
SWAPbutton.

The SWAP button will change to the SWAP TO button.

2. Move the selection bar to the other shift to be swapped and press theSWAP TO

button.

The following screen will appear:

3. Confirm the swap by selecting theSWAPbutton.
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Sick The SICK button allows the user to mark the selected scheduled employee as sick, and

schedule a replacement. The �Sick Schedule Entry� screen is displayed when this

button is selected.

The dialog box appears as follows:

Enter the appropriate information and select the OK button to replace the employee on

sick leave.
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Time Off The TIME OFF button allows the user to mark the selected scheduled employee as

taking time off and schedule a replacement. The �Leave Schedule Entry� screen is

displayed when this button is selected.

The dialog box appears as follows:

Enter the appropriate information and select the OK button to replace the employee

taking time off.

Replacements The REPLACEMENT button displays the �Replacement Schedule� screen. Any time

segments requiring replacements are listed in the screen. See the section on

Replacement Schedule for further information on replacing employees.

Can-Pay Computer Software 91

SCHEDULE - 3

S
C
H
E
D
U
L
E



Show Detail The Show Detail option from the File menuwill bring up a screen that will contain all

of the employee detail.

The following screen will appear:

The Employee Detail screen allows the user to update or insert as you would in the

notebook pages.

All Time The ALL TIME button, or the Full Schedule option in the File menu extracts and

displays all time segments including work time, vacation, sick time, etc.

Work Time The WORK TIME button, or the Schedule Work option in the File menu extracts and

displays only the shift assignments that are actual work time.

Pg. Up (prior
week)

The PAGE UP key, or the Prior Week option in the File menu will change the starting

and ending dates to correspond with the prior week and bring up those files.

Pg. Down (next
week)

The PAGE DOWN key, or the Next Week option in the File menu will change the

starting and ending dates to correspond with the next week and bring up those files.

Esc (exit) The ESC key, or the Exit option in the File menu will exit the screen.
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Daily Employee Schedule

The Daily Schedule function for the current employee group is for a one day period.

This function allows the user to mark employees as sick or on leave and select a

replacement for the shift.

This function displays a screen that allows the entry of the starting date for the day to

display. The screen will appear as follows:

The �Daily Schedule� dialog box only requires the user to enter the desired starting

date for the date range. The date must be entered in YYYY/MM/DD format.

Work Time TheWORKTIME button, or the ScheduleWork option in the File menu extracts and

displays only the shift assignments that are actual work time.

All Time The ALL TIME button, or the Full Schedule option in the File menu extracts and

displays all time segments including work time, vacation, sick time, etc.

Exit TheESCkey, theEXITbutton, or theExitoption in the Filemenu exits the function
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The Daily Employee Schedule screen will appear as follows after a date has been

selected:

The screen contains the following data:

Field Description

Date The date the user has chosen will appear at the top of the screen with the day of
the week it falls on to the right. This field is for display only.

List The List shows the shift code, start time, stop time, gross hours, employee
name, and position code for each time segment for the day.
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Update The UPDATE button allows the user to update all time segments for the employee that

has a time segment selected (selection bar highlighting the schedule entry).

The dialog box will appear as follows:

Change the appropriate data and select the OK button.

Insert The INSERT button allows the user to insert a new employee in the day schedule. A

dialog box similar to the Employee Schedule Item Update, seen above, will appear.

Fill in the data fields and select the OK button.

Delete The DELETE button is used to delete the selected schedule item from the day

schedule.
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Swap The SWAP button allows the user to swap the shifts between two existing scheduled

shifts. There must be at least two existing shifts in order to swap.

To perform a swap do the following:

1. Move the selection bar to one of the shifts to be swapped and pressing the
SWAPbutton.

The SWAP button will change to the SWAP TO button.

2. Move the selection bar to the other shift to be swapped and press theSWAP TO

button.

The following screen will appear:

3. Confirm the swap by selecting theSWAPbutton.

Homecare
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Sick The SICK button allows the user to mark the selected scheduled employee as sick, and

schedule a replacement. The �Sick Schedule Entry� screen is displayed when this

button is selected.

The dialog box appears as follows:

Enter the appropriate information and select the OK button to replace the employee

on sick leave.
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Time Off The TIME OFF button allows the user to mark the selected scheduled employee as

taking time off and schedule a replacement. The �Leave Schedule Entry� screen is

displayed when this button is selected.

The dialog box appears as follows:

Enter the appropriate information and select the OK button to replace the employee

taking time off.

Replacements The REPLACEMENT button displays the �Replacement Schedule� screen. Any time

segments requiring replacements are listed in the screen. See the section on

Replacement Schedule for further information on replacing employees.
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Leave Schedule

The following screen will appear:

Show Details The ShowDetail option from the File menu will bring up a screen that will contain all

of the employee detail.

The following screen will appear:

The Employee Detail screen allows the user to update or insert as you would in the

notebook pages.
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Pg. Up (prior
day)

The PAGEUP key, or the Prior Day option in the File menu will change the date to the

previous day and bring up the files for that day.

Pg. Down (next
day)

The PAGEDOWN key, or theNext Day option in the File menu will change the date to

the following day and bring up the files for that day.

Esc (exit) The ESC key, or the Exit option from the File menu will exit the screen.
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Employee Detail Schedule

The EmployeeDetail Schedule screen is brought upwhen this option is selected. This

option operates on a single employee for a specified date range.

The dialog box should appear as follows:

The following table contains a description of the data fields in the dialog box:

Field Description

Starting The starting date of the date range for the employee detail schedule is entered
in this data field. The format for the date is YYYY/MM/DD.

Ending The ending date of the date range for the employee detail schedule is entered in
this data field. The format for the date is YYYY/MM/DD.

Name The name of the employee to enter the schedule is entered into this data field.

Number The employee's badge number will be displayed in this field. If a payroll has
been selected the employee number will be shown in place of the badge
number. This field is for display only.

F8 (list) The F8 key, or the List option in the File menu will bring up a list of the available

employees. The names that appear in the list will depend on whether or not an

employee group has been selected (for further information see the section on

Managing Employee Groups) and the order of the names will depend on the type of

search technique set (for further information see the section onSet SeachTechnique).

Enter Items The Enter Items button, or the Enter Items option in the File menu will bring up the

dialog box in which to enter the detail schedule for the employee.

Next Employee The NEXT EMPLOYEE button, or the Next Employee option from the File menu will

move to the next employee in the employee list. The order of the listwill depend on the

type of search technique set (for further information see the Set Search Technique
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section), and/orwhether an employee group is selected (for further information see the

section on Managing Employee Groups).

Previous
Employee

The PREVIOUS EMPLOYEE button, or the Previous Employee option from the File

menu will move to the previous employee in the employee list. The order of the list

will depend on the type of search technique set (for further information see the Set

Search Technique section), and/or whether an employee group is selected (for further

information see the section on Managing Employee Groups).

Set Search
Technique

The Set Search Technique option will bring up the screen to select the type of search

carried out for employees. The search can be done by name, employee number, or

badge number. For further information see the section on Set Search Technique.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Detail Schedule Selection

After the date range and the employee name are entered in the Employee Detail

Schedule dialog box and the ENTER ITEMS button selected the Employee Schedule

Item Entry dialog box will appear. In this dialog box the schedule items that exist for

the employee will be displayed in a list.

The user may modify or delete the existing schedule items, as well as enter new

schedule items.

The list will appear similar to the following:

The dialog box contains the following data fields:

Field Description

Employee The employee name will appear in this field. This field is for display only.
The badge number will appear to the right of the employee name.

Date Range The date range that was chosen is displayed in this field below the employee
name. This field is for display only.

Schedule Items

List

The Schedule Items for Employee List will contain any previously scheduled
items. The list contains the following information from left to right: date, shift
code, premium codes, starting time, ending time, net hours, and the position
code.

F10 (save) The F10 key, the OK button, or the Save option from the File menu will permanently

save any changes made in the dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option in the File menu will exit the

screen without saving any changes.
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Display Fields When the Display Fields function in the Options menu is selected the Employee

ScheduleDetail ItemEntry screenwill automatically be displayedwhen one of the list

entries is highlighted. This allows for the details of that shift to be changed.

To activate the Display Fields simply select it from the Options menu so that a check

mark appears to the left. To turn it off select it again so that the checkmark is no longer

to the left of the option.

If the Display Fields function is turned off the user gets the same results by double

clicking on the appropriate list entry. The Display Fields function saves the user the

action of pressing the ENTER key.

Schedule Detail Entry

When a user selects a schedule item from the Employee Schedule Item Entry dialog

box the following detail screen will appear:
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Each Schedule item entry allows for the following data fields to be input:

Field Description

Date This field contains the date for the schedule entry

Shift This field contains the access code for the shift to be worked. The shift
may be a user defined or a system defined shift.

Premiums The premium code is entered in this field. A premium code is a one
character code to designate special premiums owing to the employee. A
premium is additional money on top of the shift wages for additional
responsibility. Up to 10 premium codes can be entered for an employee
per shift. The premium codes are set up in the Earning Translation Table
option in the Update menu.

Casual When a check mark appears in the Casual box the item will NOT be
copied by the copy block function.

Replacement

Start Time This field contains the starting time for the shift.

Stop Time This field contains the ending time for the shift.

Reason This field contains the reason code for the schedule entry. This must be a
valid reason code (defined through the object table).

Hours The Start Time minus the Stop Time calculates the Hours. This field is
for display only since it is automatically calculated for the user.

Position This field contains the position for the schedule entry. This must be valid
position code (defined through the object table).

Area This field area code for the schedule entry. This must be a valid area
code.

Sub Area This field contains the sub area code for the schedule entry. This must be
a valid sub area code.

Activity This field contains the activity code for the schedule entry. This must be
a valid activity code.

Sub Activity This field contains the sub activity code for the schedule entry. This must
be a valid sub activity code.

G/L Code The General Ledger code is entered into this field. This must be a valid
G/L code previously defined by the user. This field is only available
when the GrandMaster II payroll is not being used in conjunction with the
GrandMaster Suite.

Department This field contains the department code for the schedule entry. This must
be a valid department code. This field is only available when the
GrandMaster II payroll system is being used in conjunction with the
GrandMaster Suite Schedule Module.

Account This field contains the account code for the schedule entry. This must be
a valid account code. This field is only available when the GrandMaster
II payroll system is being used in conjunction with the GrandMaster Suite
Schedule Module.

Sub Account This field contains the sub account code for the schedule entry. This must
be a valid sub account code. This field is only available when the
GrandMaster II payroll system is being used in conjunction with the
GrandMaster Suite Schedule Module.
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This detail entry option will check the schedule entry data against the employee

available records. If the entered values fall outside of the declared availability a

warning message will be displayed.

Scheduled entries made through the Employee Detail Schedule entry option are

allowed to override the leave schedule entries. However leave schedule entries made

after the specific schedule entry will modify the schedule items.

F8 (list) The F8key, or theList option from the Filemenuwill bring up a list of the valid choices

for the field which contains the cursor. The fields which will have a list are shift,

position, reason, area, sub area, activity, sub activity, and department.

Save Entry The OK button, or the Save Entry option in the File menu will temporarily save the

data. A permanent save is done when the OK button in the Employee Schedule Item

Entry dialog box is selected.

Delete Entry TheDELETEbutton, or theDelete Entry option from the Filemenuwill delete the data

currently in the dialog box.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

screen without saving any changes.
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Substitute Employees

The Substitute Employees option allows the user to replace one employee with

another. The replacement done by this function is permanent.

The dialog box will appear as follows when the option is selected:

The dialog box has the following data fields:

Field Description

Start Date Starting date for replacement. The date is entered in YYYY/MM/DD format.

End Date Ending date for replacement. The date is entered in YYYY/MM/DD format.

Replace

Employee

This field is used to enter the name of the employee that will be replaced.

With Employee This field is used to enter the name of the employee that will work the shifts
assigned to the replaced employee.
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F8 (list) The F8 key, or the List option in the File menu will bring up a list of the available

employees. The names that appear in the list will depend on whether or not an

employee group has been selected (for further information see the section on

Managing Employee Groups) and the order of the names will depend on the type of

search technique set (for further information see the section onSet SeachTechnique).

Substitute
Employees

The SUBSTITUTE EMPLOYEES button will begin the processing.

Esc (exit) TheESCkey, theCANCELbutton, or theExit option in the Filemenuwill exit the dialog

box.
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Copying a Schedule Block

TheCopy Schedule Block option is used to copy a tailored schedule for a given date

range to a new date range.

F After the schedule block is copied any leave schedule entries present are applied to the
new schedule block.

F This option will not create Schedule items for an employee when an individual item for
a particular date already appears in the Schedule Item Table.

F The copy operation is restricted to the current employee group.

The following screenwill appearwhen theCopyScheduleBlock option is selected.

The dialog box contains the following data entry fields:

Field Description

Starting Block Date This field contains the starting date for the Schedule copy process.

Ending Block Date This field contains the ending date for the Schedule copy process.

Advance Block Date This field contains the advance block date for the new Schedule
block.

OK TheOKbuttonwill begin the process of copying the schedule for the date range entered

in the Starting Block Date and Ending Block Date fields to the advance block.

Cancel TheCANCELbuttonwill exit from the functionwithout copying any schedule items.
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Clear a Selection Block

The Clear Schedule Block option is used to clear schedule blocks for a given date

range.

F The clear option is restricted to the current employee group.

The following screenwill appearwhen theClearSelectionBlock option is selected.

The dialog box contains the following data entry fields:

Field Description

Starting Block Date This field contains the starting date for the schedule clearing.

Ending Block Date This field contains the ending date for the schedule clearing.

OK The OK button is pressed to Clear the Schedule block for the date range entered in the

Starting Block Date and Ending Block Date fields.

Cancel The CANCEL button is pressed to exit from the function without clearing any items.
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MASTER FILES

The Master Files menu from the main menu bar contains options that maintain the

data tables used for the preparation of GrandMaster Suite Schedules. These options

are:

n employee update, see page 112

n employee availability update, see page 122

n shift update, see page 136

n rotation update, see page 141

n position update, see page 148

n control settings update, see page 146

n calendar update, see page 156

TheMaster Files menu appears as follows:
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Employee Update

When the Employee Update option is selected a dialog box appears as follows:

To select an employee, type in your choice of the last name, employee number, or the

badge number in the name data field. The data entered must correspond to the type of

search technique that has been set.

F The employee number can only be used if a payroll has been selected.

Next Employee The NEXT EMPLOYEE button, or the Next Employee option from the File menu will

bring up the next employee in the list.

Previous
Employee

The PREVIOUS EMPLOYEE button, or the Previous Employee option from the File

menu will go back to the previous employee in the list.
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F8(list) The F8 key, or the List option in the File menu will bring up a list of employees. The

screen will appear similar to the following:

F To have the list start somewhere other than the beginning simply type in the letter(s)
corresponding to where you would like the list to begin before selecting theF8 key.

F This list will vary depending on whether or not a payroll has been selected. If no
payroll is selected all employees will appear in a list. However if a payroll is selected
only the employees in that payroll will appear in the list.

F The search technique and whether or not an employee group has been selected will
affect the order that the employees appear in the list (see Employee Selection List,
page 12).

From the list dialog box the user can insert new employees (page 115), and update or

delete (page 121) existing employees.

Search Technique The search technique gives the user several ways searching through the employee

list. The types of searches available are name, employee number, and badge number.

For more information see the section on Set Search Technique, page 2.
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OK The OK button will select the employee entered into the name data field and move to

the Employee Update screen where the employee information can be updated. The

screen will appear as follows:

The screen contains four tabs: address, ID, medical, and personal. These four screens

are described in the Inserting an Employee section beginning on page 116.

Esc (exit) The ESC key, the CANCEL button, or the Exit option in the File menu will exit the user

from the current screen.
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Inserting an Employee

To insert a new employee do the following:

1. Select theEmployee Updateoption from the Master Files menu.  The
Employee Name Selection dialog box will appear:

2. Select theF8key or theList option in the File menu.  The Employee Name
Order dialog box will appear:

3. Select theINSERTbutton.  A dialog box will appear which contains four tabs:
address, ID, medical, and personal (these screens are defined below).

4. Enter in the required information and select theOK button.
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The Address page of the notebook appears as follows:

The following table contains a description of the fields in the screen:

Field Description

Surname This field contains the surname of the employee.

Given Name The given name of the employee is entered into this field.

Address Line 1 The Address Line 1 field is used to enter in the address of the employee.

Address Line 2 is used as an extra address field if the space is needed.

City This field contains the city in which the employee lives.

Province The province of the employee should be entered into this field.

Postal Code This field is for entering the employee's postal code.
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The ID page of the notebook appears as follows:

The following table contains a description of the fields in the screen:

Field Description

S.I.N. The employee's social insurance number is entered into this field.

Badge Number The badge number of the employee is contained in this field. Using a badge
number is optional.

Treaty Number If the employee has a treaty number it may be entered in this field.

Band Name If the employee has a band name it may be entered in this field.
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The Medical page appears as follows:

The following table contains a description of the fields in the screen:

Field Description

Medical

Number

This is the medical number of this person only.

Family

Number

This is the family medical number for the entire family.

Reference

Number

This is a n additional medical reference number used by some provinces.
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The Personal page appears as follows:

The following table contains a description of the fields in the screen:

Field Description

Birth Date The birth date of the employee should be entered into this field in
YYYY/MM/DD format.

Sex Either �M� for male, or �F� for female is used to enter in the employee's sex in
this field. Data can be entered into this field using the pull down menu.

Home The home phone number of the employee can be entered into this field.

Alternate An alternate phone number used to reach the employee may be placed in this
field.

For all the notebook pages the following functions are possible:

F10 (save) The F10 key, the OK button, or the Save option from the File menu will save any

changes made within the Main Employee Data screen.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

screen without saving any changes.
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The Category page appears as follows:

The category page of the notebook contains the following data fields:

n The screen contains 10 fields that contain 10 character code.

n These codes are defined in the code validation update with the description of the
user defined code.

n These can be any codes that you want to use to sort on or categorize your group
of employees.
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Deleting Employees

To delete an existing employee follow these steps:

1. Select theEmployee Updateoption in the Master Files menu.

2. When the Employee Name Selection dialog box appears select theF8key, or
theList option in the File menu to obtain a list of employees.

3. Move the selection bar to the employee to delete.

4. Select theDELETE button at the bottom of the Employee Name Order dialog
box.

5. A message will appear asking you to confirm the deletion.  Select theYES

button to delete, or theNO button to cancel the deletion process.
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Employee Availability Update

The Employee Availability Update option allows the user to specify the days of the

week and the time of day that the employee is available for work as well as prefers to

work.

A screen containing a list similar to the following will appear when the Employee

Availability Update option is selected:

The screen lists the following from left to right: starting date, ending date, days

available, number of hours available per week and the employee's name.

Set Date Range Adate range can be specified through theSetDateRange option in the Filemenu.

F If no information has been previously entered within the date range, the list will be
empty.

Insert By selecting the INSERT button, or the Insert Item option in the File menu new data

can be inserted into the list of employee availability.

Update When one of the items in the list is highlighted, selecting the UPDATE button, or the

Update Entry option in the File menu will allow the user to update an item that has

already been entered.

Delete By selecting the DELETE button, or the Delete Entry option in the File menu the

highlighted item can be cleared from the list of employee availability.
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Additional The Additional for Employee option in the File menu, or the ADDITIONAL button

creates an additional record for the same employee as the highlighted line. The screen

is the same as the update screen. This is useful for creating availability records with

different dates for the same employee.

Entering Employee Availability

Two groups of fields may be input through the Employee Availability Update

function. The first group is used for the days of theweek, hours perweek and the times

of day that the employee can be available for work. The second group of fields can be

used to input the days and times that the employee would prefer to work.

When either the INSERT or UPDATE buttons is selected the following dialog box will

appear:
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The following table gives a description of the data fields within the dialog box:

Field Description

Employee The employee whose availability is being entered will be shown at the top
of the dialog box. This field is for display only.

Effective Date The first date of a date range pertaining to the availability times.

to The last date of a date range pertaining to the availability times.

Times Available

Days of Week The days of the week the employee is available.

Hours/Week The maximum number of hours per week for which the employee is
available to work.

Daily Hours Each day of the week is listed with two data fields to the right. The first
field is for the earliest time and the second is for the latest time the
employee is available to work on that day.

Preferred Times

Days of Week The days of the week the employee prefers to work.

Hours/Week The maximum number of hours the employee prefers to work is entered
into this field.

Daily Hours Each day of the week is listed with two data fields to the right. The first
field is for the earliest time and the second is for the latest time that the
employee prefers to work on that day.

F10 (save) The F10 key, or the Save option in the File menu will save any changes made in the

dialog box.

Esc (exit) The ESC key, or theExit option in the Filemenuwill exit the dialog boxwithout saving

any changes.

F A special system shift definition named “$NOTAVAIL” may be used to specify
specific dates and times that the employee will not be available for work.

The availability data for an employee is used to test any shift schedule data input.

Warning messages will be produced when scheduled dates and times produce a

conflict with the employee availability data input.
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Default Employee Availability

The Default Employee Availability is the same as Employee Availability the only

difference is the default Employee Availability is available for all employees and the

Employee Availability is for one employee at a time.

For information on how to fill in the Default Employee Availability screens please

refer to pages 122-124.
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Seniority List

When the user selects Seniority Lists from theMaster Files menu the following screen

will appear:

The following options are available to the user:

n Master Seniority List

n Area Seniority List
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Master Seniority List

When the user selects the Master Seniority List the following screen will appear:

Insert The Insert button allows the user insert seniority list. The following screen appears

when the insert button is pressed.
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Area Seniority Update

The area seniority update allows you to set up seniority lists for a given area, or the

master seniority list if no area has been specified.

The option first requests the area for the seniority list.

F8 (list) The F8 key or the list option from the file menu will bring up a list of all the areas.

ESC TheESCkey, CANCELbutton, or Exit option in the Filemenuwill exit the dialog box

without saving any changes.

OK TheOKbutton or update from the filemenuwill allowyou to update the seniority list.
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After the area is selected the option presents a screen showing the area and description

with the ability to select 6 lists for this area.

F8 (List) TheF8 key or list option from the filemenuwill allowyou to select a seniority list from

the given list of available seniority lists.

ESC TheESCkey, CANCELbutton, or Exit option in the Filemenuwill exit the dialog box

without saving any changes.

OK The OK button or UPDATE option from the file menu will allow you to save your

add or changes to the seniority list.
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When you are selecting your seniority list from the list of seniority lists you may

update or change the lists.

Insert The INSERT button will allow you to add a new list.

Update The UPDATE button will allow you to update a list.

Delete The DELETE button will allow you to delete a list.

OK The OK button or CANCEL button will return you to the screen where you select

seniority lists for your area.
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The seniority list update shows you the employees or the seniority list.

The following dialog box allows the data fields to be input:

Field Description

Code This field contains the name of the seniority list.

Description This field contains a description of the seniority list code.

Effective Date From This field contains the date the list is effective from.

Effective Date To This field contains the date the list is effective to.

Seniority List This field shows the order, hours, and the employee name
starting with the employee with the most seniority.
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The update an employee double click on the line or on a new line for a newemployee to

be added.

The information required for a new employee to be added is the employee name,

number of hours and the order number.

The number of hours are the hours used to determine seniority.

The order field is used to enter the position number if several employees have the same

number of hours.
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Shift Update

The Shift Update option from the Master Files menu is used to maintain the Shift

Data Table. This table is used to determine the standard work hours and earnings for a

shift.

F At least one User Defined Shift must be created for the module to schedule work time
segments.

When the Shift Update option is selected the Shift Master Update screen appears as

follows:

The only data field in this dialog box is the shift code field in which the user enters the

shift code.

F8 (list) Selecting the F8key, or theList option from theFilemenuwill bring up a list of all the

previously defined shift tables. The list will appear similar to the following:

F If no shift codes have been previously defined the list will be empty.

The screen will list the shift codes with their description to the right.
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From this screen the user can insert new shift codes (using the INSERT button), update

defined shift codes (using the UPDATE button), or delete defined shift codes (using the

DELETE button).

F10 (update) The F10 key, the OK button, or the Update option from the File menu is used to make

changes in previously defined shift codes. The shift codemust first be entered into the

shift code field.

The following data fields require input:

Field Description

Shift Code This field is used for the shift code. Access to the shift is done by entering the
shift code.

Description This field is used for a free form description of the shift. This field is
displayed on pop-up lists and is used for reports.

Start Date This field is used for the starting date of a date range in which the shift may be
used. A value of zero indicates that no starting date is defined.

Ending Date This field is used for the ending date of a date range in which the shift may be
used. A value of zero indicates that no stopping date is defined.

Start Time This field contains the standard starting time.

Stop Time This field contains the standard stopping time

Break Times The break time fields are used to define the breaks within a shift. Up to four
(4) breaks may be defined for a shift.

Break # At This field is used to contain the starting time for the break.

Length This field is used for the length of the break.

Paid Break This check box is used to indicate if the break is paid or unpaid. When a break
is unpaid it is subtracted from the worked hours when calculating net hours to
be paid.
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Field Description

Translation

Table

This field is used to enter the code for the earnings translation table that is used
to calculate overtime and premiums for a shift.

Esc (exit) The ESC key, the EXIT button, or the Exit option in the File menu will exit the dialog

box.
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Defining a New Shift Code

The Schedule Module allows the user to define any number of shifts for use in

scheduling employees. Shift codes defined by the user are referred to as User Defined

Shift Codes.

F At least one User Defined Shift must be created for the module to schedule work time
segments.

To create a new user defined shift code follow these steps:

1. Select theShift Update option in the Master Files menu.  The following dialog
box will appear:

F If the user already knows the shift code to be defined has not been done so previously
then he/she can enter the shift code directly into the Shift Master Update Selection
dialog box, and select theF10 key, or theUpdate option from the File menu. This
action will bypass the Shift Code Listing screen and bring up the Shift Earnings
Definition dialog box, therefore skip to step five of this section. Otherwise carry on
with step two.
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2. When the Shift Master Update Selection dialog box appears select theF8key,
or theList option from the File menu to bring up the list of previously defined
shift codes.  The list will appear similar to the following:

For information on the contents of the list see the previous description of this screen in

the Shift Update section of this manual, page 133.

3. Select theINSERTbutton at the bottom of the Shift Code Listing screen to enter
in a new shift code.  A dialog box will appear as follows:
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4. Enter the name of the new shift code into the Insert New Shift dialog box, and
press theOK button.  The Shift Earnings Definition dialog box will appear as
follows:

5. Fill in the data fields in the dialog box to define the new shift.

For information about the data fields within this dialog box see the previous

description of this dialog box in the Shift Update section of this manual, page 134.

6. Save the data by selecting theF10key,OK button, or theSaveoption from the
File menu when all the information has been entered correctly.
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Example:

Shift Code - DAY

Description - Day Shift

Start Date - zero (none)

Stop Date - zero (none)

Start Time - 08:30

Stop Time - 17:00

Break 1 Start - 10:30

Break 1 Length - 15

Break 1 Paid - (Paid Break)

Break 2 Start - 12:00

Break 2 Length - 30

Break 2 Paid - (Not Paid)

Break3 Start - 15:00

Break 3 Length - 15

Break 3 Paid - (Not Paid)

Earning Table - E1

Deleting an Existing Shift Code

To delete a previously defined position code follow these steps:

1. Select theShift Update option in the Master File menu.

2. When the Shift Master Update Selection dialog box appears select theF8key,
or theList option in the File menu to obtain a list of all defined shifts.

3. Move the selection bar to the shift code to delete.

4. Select theDELETE button at the bottom of the Shift Code Listing screen.

5. A message will appear asking you to confirm the deletion.  Select theYES

button to delete, or theNO button to cancel the deletion process.
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System Defined Shifts

The leave time segments are defined by the system andmay not be altered by the user.

The following table contains the system defined shifts.

Shift Description

$vacation This shift is used when vacation time is scheduled for an employee.

$sick This shift is used when sick leave is scheduled for an employee.

$training This shift is used when training time is scheduled for an employee.

$inlieu This shift is used when time off in lieu of overtime is scheduled for an employee.

$other This shift is used when other leave time is scheduled for an employee.

$notavail This shift is used when the employee will not be available for scheduling.
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Rotation Update

The Schedule Module can use standard shift rotation patterns for scheduling

employees. When this method is used the shift rotation pattern must be defined.

F The rotation pattern may contain up to 200 days. Each day may contain up to five shift
assignments. Multiple shift assignments in a day are required for split shifts or
multiple position assignments.

TheRotation Update option in theMaster Files menu updates the rotation patterns in

the Rotation Data Table.

When this option is selected the following dialog box appears:

The only data field in this dialog box is the rotation code field inwhich the user enters a

rotation code.
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F8(list) The F8 key, or the List option from the File menu will bring up a list of the rotation

codes that have been previously defined. The listwill appear similar to the following:

F If no rotation codes have been previously defined the list will be empty.

The screen will list the rotation codes with their description to the right.

From this screen the user can insert new rotation codes (using the INSERT button),

update defined rotation codes (using the UPDATE button), or delete defined rotation

codes (using the DELETE button).
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F10 (update) The F10 key, the OK button, or the Update option in the File menu is used to make

changes in previously defined rotation codes. The rotation code must first be entered

into the rotation code field.

The following data fields require input:

Field Description

Rotation The rotation code that is being defined will appear at the top of the dialog
box. This field is for display only.

Description A description of the rotation code can be entered into this field.

Number of Days The number of days the rotation contains is entered into this field. The
rotation pattern may contain up to 200 days.

Starting Date This field contains the starting date of the rotation. This pattern will not be
used for employee scheduling before this date.

Ending Date This field contains the ending date of the rotation. This pattern will not be
used for employee scheduling past this date.

List of Shift

Assignments

From left to right the list shows the day number of the rotation, the day of
the week, and up to five shifts for that day.

Esc (exit) The ESC key, the EXIT button, or the Exit option in the File menu will exit the dialog

box.
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Defining New Rotation Codes

To create a new rotation code follow these steps:

1. Select theRotation Updateoption in the Master Files menu.  The following
dialog box will appear:

F If the user already knows the rotation code to be defined and has not done so
previously then he/she can enter the rotation code directly into the Rotation Master
Update Selection dialog box, and select theF10key, or theUpdateoption from the File
menu. This action will bypass the Rotation Listing screen and bring up the Rotation
Definition dialog box, therefore skip to step five of this section. Otherwise carry on
with step two.

2. When the Rotation Master Update Selection dialog box appears press theF8

key, or theList option in the File menu to obtain a list of the defined rotation

3. codes.  The list will appear similar to the following:

For information on the contents of the list see the previous description of this screen in

the Rotation Update section of this manual, page 142.
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4. Instead of selecting an item from the list, select theINSERTbutton at the
bottom of the dialog box.

5. Type in the name of the new rotation code to be defined into the Insert New
Rotation dialog box, then select theOK button.  The Rotation Definition dialog
box will appear as follows:

6.

7. Define the new rotation code by typing information needed in the correct
data fields.

For information about the data fields within this dialog box see the previous

description of this dialog box in the Rotation Update section of this manual, page

143.

8. Select theF10key,OK button, or theSaveoption from the File menu when
all the information has been entered correctly.
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Deleting an Existing Rotation Code

To delete a previously defined position code follow these steps:

1. Select theRotation Updateoption in the Master File menu.

2. When the Rotation Master Update Selection dialog box appears select theF8

key, or theList option in the File menu to obtain a list of all defined rotations.

3. Move the selection bar to the rotation code to delete.

4. Select theDELETE button at the bottom of the Rotation Listing screen.

5. A message will appear asking you to confirm the deletion.  Select theYES

button to delete, or theNO button to cancel the deletion process.

Shift Assignments

A Shift Assignment list entry exists for each of the days in the rotation pattern.

F Each shift assignment entry allows for the specification of up to five shifts per day of
the rotation.

When the user double clicks on one of the shift assignment list entries the following

dialog box will appear:

Each shift specification allows for the input of the shift code to be included into the

pattern.

F When shifts are not assigned to a day in the rotation pattern no work segments will be
scheduled for that day.

F8 (list) The F8key, or theList option in the Filemenuwill bring up a list of previously defined

shifts.
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F10 (save) The F10 key, the OK button, or the Save option in the File menu will save the changes

made in the dialog box.

Esc (exit) TheESCkey, CANCELbutton, or theExit option from theFilemenuwill exit the screen

without saving any changes.
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Position Update

Selecting the Position Update option brings up the PositionMaster Update Selection

screen. This screen appears as follows:

The position namemust be entered into this dialog box. This can be done by typing the

position name in or selecting it from a list of position names.

F8(list) Selecting the F8 key, or theList option from the File menu will bring up a list of all the

defined position names. The list will appear similar to the following:

F If no position codes have been previously defined the list will be empty.

The screen will list the position codes with their description to the right.

From this screen the user can insert new position codes (using the INSERT button),

update defined position codes (using the UPDATE button), or delete defined position

codes (using the DELETE button).
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OK The OK button, or the Update option from the File menu is used to make changes in

previously defined position codes. The position code must first be entered into the

position code field. The dialog box will appear as follows:

The following data fields require input:

Field Description

Code This field displays the Position Code.

Description This field displays the position description.

Class This field displays a model type if one has been or is to be assigned.

Pay Table If the position pay rate is derived from a rate table the appropriate rate table
code displayed or entered here.

Start Date This field contains the starting date of the position update.

End Date This field contains the ending date of the position update.

Distribution This field displays the distribution table that the position has been assigned to.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the dialog

box.
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Defining a New Position Code

To create a new position code follow these steps:

1. Select thePosition Updateoption in the Master Files menu.  The Position
Master Update Selection screen will appear as follows:

F If the user already knows the position code to be defined and has not done so
previously then he/she can enter the position code directly into the Position Master
Update Selection dialog box, and select theF10key, or theUpdateoption from the File
menu. This action will bypass the Position List Screen and bring up the Position
Update dialog box, therefore skip to step five of this section. Otherwise carry on with
step two.

2. Select theF8key, or theList option from the File menu to obtain a list of all
the previously defined position codes.  The list will appear similar to the
following:

For information on the contents of the list see the previous description of this screen in

the Position Update section of this manual, page 148.
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3. Select theINSERTbutton at the bottom of the dialog box.

4. Enter the name of the new position code into the Insert New Position dialog
box, then select theOK button.  The Position Update screen will appear:

5.

6. Enter the information needed to define the position code that appears in the
dialog box.

For information about the data fields within this dialog box see the previous

description of this dialog box in the PositionUpdate section of thismanual, page 149.

7. Save the data by selecting theF10key,OK button, or theSaveoption from the
File menu when all the information has been entered correctly.
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Deleting an Existing Position Code

To delete a previously defined position code follow these steps:

1. Select thePosition Updateoption in the Master Files menu.

2. When the Position Master Update Selection dialog box appears select theF8

key, or theList option in the File menu to obtain a list of all defined positions.

3. Move the selection bar to the position code to delete.

4. Select theDELETE button at the bottom of the Position List Screen.

5. A message will appear asking you to confirm the deletion.  Select theYES

button to delete, or theNO button to cancel the deletion process.
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Code Validation Update

The code validation update function allows you to update the various user defined

code tables provided by GrandMaster Suite.

When the user select Code Validation Update the following screen will appear:

The following table gives a description of the screen:

Field Description

Group Name The group name is the name of the code table to update a list of the code table
may be obtained by using the �F8� list function.

Object Name The object name is the code value to update.

The system established code table group names all start with a �$� character. (Eg:

$area is the group name for the �Area� Code Table.
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Control Settings Update

The option allows the user to control:

n schedule generation by specifying the starting date and days to schedule,

n time entry by specifying the starting date and the days for the time entry, and

n payroll update by specifying the payroll starting date and days for the payroll
for each payroll.

The following dialog box will appear after selecting the Control Setting Update

option in the Master File menu:
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The following table gives a description of the fields within the dialog box:

Field Description

Schedule Generation

Start Date The starting date from which to begin generating the schedule is entered into
this data field.

Days to

Schedule

Time Entry

Start Date The starting date for the time entry is entered into this field.

Days for Time

Entry

Payroll Update

Payroll This field contains the name of the currently selected payroll. This field is for
display only.

Start Date The start date for updating the payroll is entered into this field.

Days for

Payroll

F10 (save) The F10 key, OK button, or the Save option from the File menu will save any changes

made to the data within the dialog box.

Esc (exit) The ESC key,CANCELbutton, or theExit option from the Filemenuwill exit the dialog

box without saving any changes.
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Calendar Update

The ScheduleModule allows the use of special processing for specified dates through

a system calendar. This calendar may be used to specify statutory and special

company holidays. When the organization chart position requirements are used the

calendar may also be used to control the inclusion or exclusion of positions for

scheduling.

the calendar Update option brings up the following dialog box when selected:

The date can be entered by typing it in or by selecting a defined calendar date from a

list.

F8(list) A list of all the defined calendar dates will appear if the F8 key is pressed. The list will

appear as follows:
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F If no dates have been previously defined then the list will appear empty.

The list contains the following information from left to right: date, stat holiday code,

company holiday code, excludes (a 1 character code, up to 100 can be entered), and

includes (a 1 character code, up to 100 can be entered).

From this screen the user can insert new calendar dates (using the INSERT button),

update defined calendar dates (using the UPDATE button), or delete defined calendar

dates (using the DELETE button).

F10 (update) The F10 key, theOK button, or theUpdate option in the Filemenuwill allow the user to

change the data for the currently entered date. Adatemust be entered into theCalendar

Update Date Selection dialog box for this function to work. A dialog box will appear

as follows:

The following data fields require input:

Field Description

Includes This field may hold up to 100 one character codes to be flagged as included in
the schedule processing.

Excludes This field may hold up to 100 one character codes to be flagged as excluded
from the schedule processing.

Stat Holiday This field holds the code to define the date as a statutory holiday.

Company

Holiday

This field holds the code to define the date as a company holiday.

Esc (exit) The ESC key, the CANCEL button or the Exit option from the File menu will exit the

dialog box.
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Defining a New Calendar Date

To define a new calendar date follow these steps:

1. Select theCalendar Updateoption in the Master File menu. The Calendar
Update Date Selection dialog box will appear as follows:

F If the date to be defined is already known without checking which dates have been
previously defined in the system then enter the date directly into the Calendar Update
Date Selection dialog box, and select theF10key, or theUpdateoption from the File
menu. This action will bypass the Calendar List Screen and bring up the Calendar
Update dialog box, therefore skip to step five.  Otherwise, carry on with step two.

2. When the Calendar Update Date Selection dialog box appears select theF8

key, or theList option from the File menu to obtain a list of all defined
calendar dates.  The Calendar List Screen will appear as follows:

For information about the contents of the list see the previous description of this screen

in the Calendar Update section of this manual, page 156.

3. Select theINSERTbutton at the bottom of the Calendar List Screen to enter in a
new calendar date. A dialog box will appear as follows:
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4. Enter the date in the Insert New Date dialog box, and select theOK button.
The Calendar Update dialog box will appear as follows:

5. Within the Calendar Update dialog box enter the required information to
define the calendar date.

For information about the data fields within this dialog box see the previous

description of this dialog box in the Calendar Update section of this manual, page

157.

6. Select theF10key,OK button, or theSaveoption from the File menu when
all the information has been entered correctly.

Can-Pay Computer Software 159

MASTER FILES - 4

M
A

S
T

E
R

F
I
L

E
S



Deleting an Existing Calendar Date

To delete a previously defined calendar date follow these steps:

1. Select theCalendar Updateoption in the Master File menu.

2. When the Calendar Update Date Selection dialog box appears press theF8 key,
or theList option from the File menu to obtain a list of all defined calendar
dates.

3. Move the selection bar to the calendar date to delete.

4. Select theDELETE button at the bottom of the Calendar List Screen.

5. A message will appear asking you to confirm the deletion. Select theYES

button to delete, theNO button to cancel the deletion process.
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Import/Export

When the user selects the Import/Export menu the following screen will appear:

The following options are available to the user:

n Import Employee Records

n Export Employee Records
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Employee Import

The Employee Master File Import option imports employee information from a

comma delimited ASCII file or a fixed file format.

This function allows the user to select the date format, the data fields to be included in

the import and to select the import file format.

The following dialog box appears when the Employee Import is chosen:

Saving... The selectionmade by the user can be saved by selecting the Save Parameters option

in the File menu.
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File Name for
Export

This field is the name of the file for the imported employee imported information.

When entering a file name for the import file the file is expected to be in the current

drive and directory. You may import from elsewhere by specifying the drive and

directories before the file name. The file information can be up to 60 characters long.

Eg) P:\GRANDDEV\SOURCE\MYFILE.TXT

F You must specify if the import file is a fixed length or delimited file type

Date Format
Selection

Adate format is selected for the import when the box to the left of the date format has a

check mark.

The date format selection allows for the following date options:

n DDMMYY

n MMDDYY

n DDMMMYY

If the box to the left of the YYYY year field has a check mark the year will be in the 4

digit format. EG) DDMMYY will become DDMMYYYY

When you are changing the year into a 4 digit year from 2 digits in the import file you

must specify the following:

n Starting Century

n Century Break

The starting century is the first two numbers of the century numbers we are starting

with. Eg) 19

The century break is the last two number of the century that the century will change

on Eg) 00 this means that when we hit 1999 the next century will be 2000.
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The following dialog box appears for the employee hours import when the delimited

tab is chosen:
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Delimited Field
Position
Selection

A data field is selected for the import when the box to the right of the field has the

position number. If the position number is zero that field will not be imported. That

field will be written in the file record according to the position number.

The report field selection allows for the inclusion of the following data fields from the

master file:

Fields Description

Badge When this field is checked the badge number of the employee will be imported.

Name When this field is checked the name of the employee will be imported.

Surname When this field is checked the surname of the employee will be imported.

Given When this field is checked the given name of the employee will be imported.

S.I.N. When this field is checked the social insurance number of the employee will be imported.

Birth Date When this field is checked the birth date of the employee will be imported.

Start Date When this field is checked the starting date of the employee will be imported.

End Date When this field is checked the ending date of the employee will be imported.

ADD1 When this field is checked the address line 1 of the employee will be imported.

ADD2 When this field is checked the address line 2 of the employee will be imported.

City When this field is checked the city of the employee will be imported.

Prov When this field is checked the province of the employee will be imported.

Postal Code When this field is checked the postal code of the employee will be imported.

Department When this field is checked the department of the employee will be imported.

Account When this field is checked the account of the employee will be imported.

Sub

Account

When this field is checked the sub account of the employee will be imported.

Home

Phone

When this field is checked the home phone of the employee will be imported,

Alt. Phone When this field is checked the alternate phone number of the employee will be imported.

Medical When this field is checked the medical number of the employee will be imported.

Family

Med.

When this field is checked the family med. number of the employee will be imported.

Treaty When this field is checked the treaty number of the employee will be imported.

Band When this field is checked the band number of the employee will be imported.

Position When this field is checked the position of the employee will be imported.

Sex (M/F) When this field is checked the sex code of the employee will be imported.
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The following dialog box appears for the employee hours import when the fixed tab is

chosen:
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Fixed Field
Position
Selection

A data field is selected for the import when the box to the right of the field has the

position number. If the position number is zero that field will not be imported. That

field will be written in the file record according to the position number.

The report field selection allows for the inclusion of the following data fields from the

master file:

Fields Description

Badge When this field is checked the badge number of the employee will be imported.

Name When this field is checked the name of the employee will be imported.

Surname When this field is checked the surname of the employee will be imported.

Given When this field is checked the given name of the employee will be imported.

S.I.N. When this field is checked the social insurance number of the employee will be imported.

Birth Date When this field is checked the birth date of the employee will be imported.

Start Date When this field is checked the starting date of the employee will be imported.

End Date When this field is checked the ending date of the employee will be imported.

ADD1 When this field is checked the address line 1 of the employee will be imported.

ADD2 When this field is checked the address line 2 of the employee will be imported.

City When this field is checked the city of the employee will be imported.

Prov When this field is checked the province of the employee will be imported.

Postal Code When this field is checked the postal code of the employee will be imported.

Department When this field is checked the department of the employee will be imported.

Account When this field is checked the account of the employee will be imported.

Sub

Account

When this field is checked the sub account of the employee will be imported.

Home

Phone

When this field is checked the home phone of the employee will be imported,

Alt. Phone When this field is checked the alternate phone number of the employee will be imported.

Medical When this field is checked the medical number of the employee will be imported.

Family

Med.

When this field is checked the family med. number of the employee will be imported.

Treaty When this field is checked the treaty number of the employee will be imported.

Band When this field is checked the band number of the employee will be imported.

Position When this field is checked the position of the employee will be imported.

Sex (M/F) When this field is checked the sex code of the employee will be imported.

Employee Export

TheEmployeeMaster File Export option exports employee information to a comma

delimited ASCII file.
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This function allows the user to select the filename for exported data, the data fields to

be included in the export and to select the objects to be included or excluded in the

export.

The following dialog box appears when the Employee Export is chosen:

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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File Name for
Export

This field is the name of the file for the exported employee exported information.

When entering a file name for the export the file will be created in your current drive

and directory. You may place it elsewhere by specifying the drive and directories

before the filename. The filename information can be up to 60 characters long. Eg)

P:\GRANDDEV\SOURCE\MYFILE.TXT

Date Range
Selection

To limit the range of the report starting and ending dates may be entered. If both dates

are zero the entire report will be printed. If only the ending date is zero the report will

print from the starting date until the end of the report.

Date Format
Selection

Adate format is selected for the export when the box to the left of the date format has a

check mark.

The date format selection allows for the following date options:

n DDMMYY

n MMDDYY

n YYMMDD

n DDMMMYY

If the box to the left of the YYYY year field has a check mark the year will be in the 4

digit format. Eg) DDMMYY will become DDMMYYYY.
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The following dialog box appearswhen the fields tab is chosen in the employeemaster

export:
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Export Field
Position
Selection

A data field is selected for the export when the box to the right of the field has the

position number. If the position number is zero that field will not be exported. That

field will be written in the file record according to the position number.

The report field selection allows for the inclusion of the following data fields from the

master file:

Fields Description

Badge When this field is checked the badge number of the employee will be exported.

Name When this field is checked the name of the employee will be exported.

Surname When this field is checked the surname of the employee will be exported.

Given When this field is checked the given name of the employee will be exported.

S.I.N. When this field is checked the social insurance number of the employee will be exported.

Birth Date When this field is checked the birth date of the employee will be exported.

Start Date When this field is checked the starting date of the employee will be exported.

End Date When this field is checked the ending date of the employee will be exported.

ADD1 When this field is checked the address line 1 of the employee will be exported.

ADD2 When this field is checked the address line 2 of the employee will be exported.

City When this field is checked the city of the employee will be exported.

Prov When this field is checked the province of the employee will be exported.

Postal Code When this field is checked the postal code of the employee will be exported.

Department When this field is checked the department of the employee will be exported.

Account When this field is checked the account of the employee will be exported.

Sub

Account

When this field is checked the sub account of the employee will be exported.

Home

Phone

When this field is checked the home phone of the employee will be exported,

Alt. Phone When this field is checked the alternate phone number of the employee will be exported.

Medical When this field is checked the medical number of the employee will be exported.

Family

Med.

When this field is checked the family med. number of the employee will be exported.

Treaty When this field is checked the treaty number of the employee will be exported.

Band When this field is checked the band number of the employee will be exported.

Position When this field is checked the position of the employee will be exported.

Sex (M/F) When this field is checked the sex code of the employee will be exported.
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REPORTS

TheReportsmenu from themainmenu bar is used to print reports containing the data

from the GrandMaster Suite Scheduling system.

The Reports menu appears as follows:

The report generation process will only include those employees that are part of the

current employee group.

The Schedule Module provides two classes of reports, system defined reports, and

custom reports.

The date ranges entered limit the range of the report to only those records that fall

within the selected date range.

Custom reports are discussed in the section on custom report definition and

generation.

System defined reports have a standard format. The data fields included in the report

may be modified by the user to eliminate any that are not being used.

Can-Pay Computer Software 172

REPORTS - 5

R
E
P
O
R
T
S



Standard Reports

Time Cards This report is used to print time cards.

Employee Schedule This report is used to print the employee schedule report.

Weekly Schedule This report is used to print the weekly schedule.

Calendar Schedule This report is used to print the calendar schedule.

Homecare Employee

Worksheet

This report is used to print the homecare employee worksheet.

Homecare Client Work

Worksheet

This report is used to print a client homecare worksheet.

Homecare Client List This report is used to print a homecare client list.

Vacation Leave Schedule This report is used to print the employee vacation schedule
report.

Sick Leave Schedule This report is used to print the employee sick leave schedule
report.

Time off in lieu Schedule This report is used to print the employee time off in lieu
schedule report.

Training Schedule This report is used to print the employee training schedule
report.

Other Leave Schedule This report is used to print the other leave schedule report.

All Leave Schedule This report is used to print the all leave schedule report.

Shift Table Report This report is used to print the contents of the shift table.

Position Table Report This report is used to print the contents of the position table.

Rotation Table Report This report is used to print the contents of the rotation table.

Calendar Report This report is used to print the contents of the system calendar.

Availability Report This report is used to print the employee availability report.
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General Operation

The report program presents the user with a data selection screen that shows the data

fields selected according to the default parameters saved for the report.

The user may change the data field selections for the report. These changes may be

saved as the default selection for the reportwith theSaveParametersmenu choice.

The usermay select a subset of the user defined items in the system for inclusion in the

report. A maximum of one hundred items may be included in the subset.

After the appropriate selections are made the user can print the report by pressing the

PRINT REPORT button.

Printer Setup

The Printer setup option allows for the user to select a printer, select different fonts,

and to select the orientation for the print job.

Please refer to page of the printer chapter for more information on printer setups.

Can-Pay Computer Software 174

REPORTS - 5

R
E
P
O
R
T
S



Time Cards

The Time Card Report option prints a listing of the time cards.

This function allows the user to select the date range for the report, the data fields to

include in the report, the card specification, the time card report layout, the sort order

for the report, and to select the area to include or exclude in the report.

The dialog box for the Time Card Report option in the report menu appears as

follows:

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report youmay enter the starting and ending date. If both dates

are zero the entire report will be printed. If only the ending date is zero both the reports

will be printed from the starting date until the end of the report.

Report Fields
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following 5 heading fields and

13 body fields:

Time Card
Heading Area

Field Description

Name This field prints the name of the employee

Badge This field prints the badge number of the employee

Employee Number This field prints the employee number of the employee

Page This field prints the page number of the time cards

Week This field prints the ending date of the time card

Time Card Body
Area

Field Description

Day This field prints the day of the week

Date This field prints the date

Shift This field prints the shift

Start Time This field prints the starting time

End Time This field prints the ending time

Hours This field prints the hours

Premium This field prints the premium code of the shift

Position This field prints the position of the time card

Reason This field prints the reason

Area This field prints the area

Sub Area This field prints the sub area

Activity This field prints the activity

Sub Activity This field prints the sub activity
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Selects Selection The dialog box for the t ime card select ion appears as fol lows:

Area To choose area for the Employee Time Card Report select the Select Area object.

For instructions on how to select areas refer to page 5 of the common selection screen

chapter. If you have selected shifts the message Exclude selections or Include

selections will be displayed beside the selection button when you return to the select

report objects dialog box.
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Layout Selection The dialog box for the timecard layout appears as follows:

Defaults The default selections can be re-displayed by selecting the default selections in the File

menu. If youwish to always use the defaults select the Save Parameters option in the

File menu.
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In order to design a report layout you must specify the following 3 things:

n Off- Set

n Column

n Field Length

Off-Set This is the line offset used for printing the time card information. Eg) if you want this

field to print on the first line of this time card information use an off-set of zero. If it is

to follow on the second line use an off-set of 1. You may have as many off-sets as you

need to print all the fields you have selected.

Column This is the character position on the print line for the time card information. Eg) if the

field is to start 5 spaces in from the left hand margin enter a 6 in the column field. The

column numbers are only limited by the number of characters you can print on each

line of your selection page.

Field Length This is the number of characters that make up the field. Eg) employee number is 10

characters long. If you want to see the entire employee number enter 10 in the field

length. If you are doing the date which is 10 characters you may choose to print only

the last 5 giving you mm/dd. The date field is the only field that takes the characters

from the right hand side.

F If you asked to print the day of the week or the date, these fields will print even if there
is no other time card information for that day.

Print Sample
Card

If you click on the print sample card button a sample time cardwill be printed for you to

print you sample card layout.
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Sizes Selection The following box for the timecard sizes appears as follows:
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Card Selection The following dialog box for the card appears as follows:

In laying out the report the other things the program needs to know is:

1. The number of days per time card.  Most timecards are for 7 or 14 days.

2. The number of lines your timecard will hold.  Most timecards are 21 lines
long.

3. The line the timecard body will start on.  This means that after the heading
fields are printed the timecard information will start on the line number.

4. The body format allows you to print body headings or not.  If you ask for the
body heading you must specify the line the heading is to appear on.

5. The heading format allows you to print header legend or not.  The text to the
right of the print yes or no box will show you the printable legend.

F When you specify your heading fields make sure that they are where the timecard body
will start on, that no fields are set to print on top of one another and that you don't
specify columns past the right edge of your time card.
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Schedule Reports

The Schedule Reportsmenu from themenu bar is used to print schedule reports from

the schedule data.

The Schedule Reports sub menu appears as follows:

F Schedule Reports

n Employee Schedule

n Weekly Schedule

n Calendar Schedule
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Employee Schedule Report

The Employee Schedule Report option presents a listing of the detail schedule for

each employee.

This function allows the user to select the date range for the report, the data fields to be

included in the report, the sort order for the report, and to select the objects to be

included or excluded in the report.

The following dialog box appears when the Employee Schedule Report option is

chosen:

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File Menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The Report field selection allows for inclusion of the following data fields:

Field Description

Employee When this field is checked the name of the employee having the
employee schedule will be printed on the report.

Date When this field is checked the date for the employee schedule will be
printed on the report.

Start Time When this field is checked the starting time for the employee schedule
will be printed on the report.

End Time When this field is checked the ending time for the employee schedule
will be printed on the report.

Area When this field is checked the area for the employee schedule will be
printed on the report.

Sub Area When this field is checked the sub area for the employee schedule will be
printed on the report.

Activity When this field is checked the activity for the employee schedule will be
printed on the report.

Sub Activity When this field is checked the sub activity for the employee schedule
will be printed on the report.

Badge When this field is checked the badge number of the employee having the
employee schedule will be printed on the report.

Hours When this field is checked the hours for the employee schedule will be
printed on the report.

Position When this field is checked the position for the employee schedule will be
printed on the report.

Reason When this field is checked the reason for the employee schedule will be
printed on the report.

Shift When this field is checked the shift for the employee schedule will be
printed on the report.

Client When this field is checked the client for the employee schedule will be
printed on the report.

F The client field is only available when the homecare module is installed.
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The following dialog box appears when the sort tab is chosen:

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections:

n Employee - Employee Name

n Shift - User defined shift code & employee name

n Area - User defined area code & employee name

n Area, Position - User defined area position & employee name

n Area, Shift - User defined area shift & employee name

n Position - User defined position code & employee name

n Position, Area - User defined position code & area code & employee name

n Position, Shift - User defined position code & shift code & employee name
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The following dialog box appears when the select tab is chosen:

Select Report
Objects

The Select Report Objects selection for the report allows for the following selection

options:

n Shift - User defined shift code

n Position - User defined position code

n Reason - User defined reason code

n Area - User defined area code

n Sub Area - User defined sub area code

n Activity - User defined activity code

n Sub Activity - User defined sub activity code
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Select Report
Objects

The Select Report Objects selection for the report allows for the following selection

options:

Shift For instructions on how to select shifts refer to page 11 of the common selection screen

chapter. If you have selected shifts the message Exclude selections or Include

selections will be displayed beside the SELECT SHIFTS button when you return to the

select report objects dialog box.

Position For instructions on how to select positions refer to page 9 of the common selection

screen chapter. If you have selected positions the message Exclude selections or

Include selections will be displayed beside the SELECT POSITIONS button when you

return to the select report objects dialog box.

Reason For instructions on how to select reasons refer to page 10 of the common selection

screen chapter. If you have selected reasons themessageExclude selections or Include

selections will be displayed beside the SELECTREASON button when you return to the

select report objects dialog box.

Area For instructions on how to select area refer to page 5 of the common selection screen

chapter. If you have selected area the message Exclude selections or Include

selections will be displayed beside the SELECT AREA button when you return to the

select report objects dialog box.

Sub Area For instructions on how to select sub area refer to page 16 of the common selection

screen chapter. If you have selected sub area the message Exclude selections or

Include selections will be displayed beside the SELECT SUB AREA button when you

return to the select report objects dialog box.

Activity For instructions on how to select activity refer to page 4 of the common selection

screen chapter. If you have selected activity themessageExclude selections or Include

selectionswill be displayed beside the SELECTACTIVITYbuttonwhen you return to the

select report objects dialog box.

Sub Activity For instructions on how to select sub activity refer to page 15 of the common selection

screen chapter. If you have selected sub activity the message Exclude selections or

Include selections will be displayed beside the SELECT SUB ACTIVITY button when

you return to the select report objects dialog box.
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Weekly Schedule Report

TheWeekly Schedule Report option presents a weekly format listing of the schedule

information for each employee.

This function allows the user to select the date range for the report, the format for the

report (one week or two weeks), the data fields to include in the report, the sort order

for the report, and to select the shift to include in the report.

The following dialog box appears when the Weekly Schedule Report option is

chosen:

Saving... The selections made by the user can be saved by selecting the Save Parameters

option in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The Report field selection allows for inclusion of the following data fields:

Field Description

Employee When this field is checked the name of the employee having the weekly
schedule will be printed on the report.

Date When this field is checked the date for the weekly schedule will be
printed on the report.

Start Time When this field is checked the starting time for the weekly schedule will
be printed on the report.

End Time When this field is checked the ending time for the weekly schedule will
be printed on the report.

Area When this field is checked the area for the weekly schedule will be
printed on the report.

Sub Area When this field is checked the sub area for the weekly schedule will be
printed on the report.

Activity When this field is checked the activity for the weekly schedule will be
printed on the report.

Sub Activity When this field is checked the sub activity for the weekly schedule will
be printed on the report.

Badge When this field is checked the badge number of the employee having the
weekly schedule will be printed on the report.

Hours When this field is checked the hours for the weekly schedule will be
printed on the report.

Position When this field is checked the position for the weekly schedule will be
printed on the report.

Reason When this field is checked the reason for the weekly schedule will be
printed on the report.

Shift When this field is checked the shift for the weekly schedule will be
printed on the report.

Client When this field is checked the client for the weekly schedule will be
printed on the report.

F The client field is only available when the homecare module is installed.
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The following dialog box appears when the sort tab is chosen:

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections:

n Employee - Employee Name

n Shift - User defined shift code & employee name

n Area - User defined area code & employee name

n Area, Position - User defined area code &  position code & employee name

n Area, Shift - User defined area code & shift code & employee name

n Position - User defined position code & employee name

n Position, Area - User defined position code & area code & employee name

n Position, Shift - User defined position code & shift code & employee name

Can-Pay Computer Software 190

REPORTS - 5

R
E
P
O
R
T
S



The following dialog box appears when the format tab is chosen:

Select Report
Format
Selection

The report format selection for the report allows for the following weekly format

options:

n Single Week

n Two Weeks

n Three Weeks

n Four Weeks

F The type of printer and printer fonts will determine the number of weeks that maybe
printed across the page.

Shift To choose shifts for the Weekly Schedule Report select the Select Shifts object.

For instructions on how to select shifts refer to page 11 of the common selection screen

chapter. If you have selected shifts the message Exclude selections or Include

selections will be displayed beside the selection button when you return to the select

report objects dialog box.
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Calendar Schedule Report

The Calendar Schedule Report option presents a calendar format listing of the

schedule information for each employee.

This function allows the user to select the date range for the report, the data fields to be

included in the report, the sort order for the report, and to select the objects to be

included or excluded in the report.

The following dialog box appears when the Calendar Schedule Report option is

chosen:

Saving... The selections made by the user can be saved by selecting the Save Parameters

option in the File menu.

Shift To choose shifts for the Calendar Schedule Report select the Select Shifts object.

For instructions on how to select shifts refer to page 11 of the common selection

screen chapter. If you have selected shifts themessage Exclude selections or Include

selections will be displayed beside the selection button when you return to the select

report objects dialog box.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The Report field selection allows for inclusion of the following 14 data fields:

Field Description

Employee When this field is checked the name of the employee having the calendar
schedule will be printed on the report.

Date When this field is checked the date for the calendar schedule will be
printed on the report.

Start Time When this field is checked the starting time for the calendar schedule will
be printed on the report.

End Time When this field is checked the ending time for the calendar schedule will
be printed on the report.

Area When this field is checked the area for the calendar schedule will be
printed on the report.

Sub Area When this field is checked the sub area for the calendar schedule will be
printed on the report.

Activity When this field is checked the activity for the calendar schedule will be
printed on the report.

Sub Activity When this field is checked the sub activity for the calendar schedule will
be printed on the report.

Badge When this field is checked the badge number of the employee having the
calendar schedule will be printed on the report.

Hours When this field is checked the hours for the calendar schedule will be
printed on the report.

Position When this field is checked the position for the calendar schedule will be
printed on the report.

Reason When this field is checked the reason for the calendar schedule will be
printed on the report.

Shift When this field is checked the shift for the calendar schedule will be
printed on the report.

Client When this field is checked the client for the calendar schedule will be
printed on the report.

F The client field is only available when the homecare module is installed.
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Sort Order
Selection

The sort order selection for the report allows for the following sort order selections:

n Employee - Employee Name

n Shift - User defined shift code & employee name

n Area - User defined area code & employee name

n Area, Position - User defined area position code & employee name

n Area, Shift - User defined area shift code & employee name

n Position - User defined position code & employee name

n Position, Area - User defined position code & area code & employee name

n Position, Shift - User defined position shift code  & employee name
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HomeCare Reports

TheHomeCare Reportsmenu from the menu bar is used to print HomeCare reports

from the Homecare data.

The HomeCare Reports sub menu appears as follows:

F HomeCare Reports

The following homecare reports are available:

n Employee Worksheet

n Client Worksheet

n Client List
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Employee
Worksheet

The Employee Schedule Worksheet option prints the detailed employee schedule

worksheet showing the scheduled clients.

Please refer to page 288 of the Home Care chapter for more information.

Client Schedule
Worksheet

TheClient ScheduleWorksheet option prints the detailed client schedule worksheet

showing the schedule employees

Please refer to page 303 of the homecare chapter for more information on homecare

modules.

Client List The Home Care Client List option prints the client list.

Please refer to page 307 of the home care chapter for more information on home care

modules.
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Leave Schedule Reports

The Leave Schedule Reports submenu appears as follows:

F Leave Schedule Reports

The following Leave Schedule reports are available:

n Vacation Report

n Sick Leave Report

n Training Report

n In Lieu Report

n Other Leave Report

n All Leave Report
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Vacation Report

The Vacation Report option prints a listing of the vacation reasons for each

employee.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the reasons to include or

exclude in the report.

If a single employeewas selected before running this program only that employeewill

be printed. The employee name will be shown after the report name at the top of the

window when a single employee has been selected.

The dialog box for the vacation report option in the reportsmenu appears as follows:
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Saving.. The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File Menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A report field is selected for the report when the box to the left of the field has a check

mark.

The report field selection for the report allows for the inclusion of the following data

fields.

Field Description

Employee When this field is checked the name of the employee having the vacation
leave will be printed on the report.

Reason When this field is checked the vacation leave reason will be printed on the
report.

Start Date When this field is checked the start date for the vacation leave will be
printed on the report.

End Date When this field is checked the ending date for the vacation leave will be
printed on the report.

Start Time When this field is checked the starting time for the vacation leave will be
printed on the report.

End Time When this field is checked the end time for the vacation leave will be
printed on the report.

Description When this field is checked the vacation leave description will be printed on
the report.

Badge When this field is checked the badge number of the employee having the
vacation leave will be printed on the report.

Sort Order
Selection

The sort order selection for the report allows the following sort order selections:

n Employee - Employee name

n Date - Starting date of the vacation

n Reason - Vacation reason
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Select Reasons
Selection

To choose vacation reasons for the report select the Select Reasons object and a list of

all defined reasons will appear as follows:

The reasons are selected by clicking on the desired reason with the mouse once, this

reason will now be highlighted. Any number of reasons may be selected by repeating

this procedure.

When all the desired reasons are selected press the OK button.

To de-select a single reason simply click on the highlighted reason and it will no

longer be selected. To de-select all the selected reasons click on theClear Selections

button.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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Sick Leave Report

The Sick Leave Report option prints a listing of the sick leave reasons for each

employee.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the reasons and include

illnesses to include or exclude in the report.

If a single employeewas selected before running this program only that employeewill

be printed. The employee name will be shown after the report name at the top of the

window when a single employee has been selected.

The dialog box for the Sick Leave Report option in the reports menu appears as

follows:
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Saving.. The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A report field is selected for the report when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following data fields.

Field Description

Employee When this field is checked the name of the employee having the sick leave
will be printed on the report.

Reason When this field is checked the sick leave reason will be printed on report.

Illness When this field is checked the sick leave illness will be printed on the
report.

Start Date When this field is checked the starting date for the sick leave will be printed
on the report.

End Date When this field is checked the ending date for the sick leave will be printed
on the report.

Start Time When this field is checked the starting time for the sick leave will be
printed on the report.

End Time When this field is checked the ending time for the sick leave will be printed
on the report.

Description When this field is checked the description for the sick leave will be printed
on the report.

Badge When this field is checked the badge number of the employee having the
sick leave will be printed on the report.

Sort Order
Selection

The sort order selection for the report allows the following sort order selections:

n Employee - Employee name

n Date - Starting date of sick leave

n Reason - sick leave reason

n Illness - sick leave illness
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Select Reason
Selection

To choose sick leave reasons for the report select theSelectReasons object and a list of

all defined reasons will appear as follows:

The reasons are selected by clicking on the desired reason with the mouse once, this

reason will now be highlighted. Any number of reasons may be selected by repeating

this procedure.

When all the desired reasons are selected press the OK button.

To de-select a single reason simply click on the highlighted reason and it will no

longer be selected. To de-select all the selected reasons select the Clear Reasons

option in the file menu.

When you are selecting certain reasons you may include or exclude all the selected

reasons in the report. This is done by clicking on the Include or Exclude object.

If you have selected reasons the message EXCLUDE SELECTIONS or INCLUDE

SELECTIONS will be displayed beside the Select Reasons object.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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Illness Selection To choose illnesses for the Sick Leave Report select the Select Illnesses object. A list

of all defined illnesses will appear as follows:

The illnesses are selected by clicking on the desired illnesseswith themouse once, this

illnesses will now be highlighted. Any number of illnesses may be selected by

repeating this procedure.

When all the desired illnesses are selected press the OK button.

To de-select a single illness simply click on the highlighted illness and itwill no longer

be selected. To de-select all the selected illnesses select the Clear Illnesses object.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and you may not want to see the

entire description printed in all cases. If you select theFirst Paragraph option in the

report it will print all the description information up to the first time you pressed the

ENTER key.
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Training Report

TheTrainingReport option prints a listing of the training reasons for each employee.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the reasons to include or

exclude in the report.

When this is run from the employee menu before running this program only that

employee will be printed. The employee name will be shown after the report name at

the top of the window when a single employee has been selected.

The dialog box for theTrainingReport option in the reportsmenu appears as follows:

Saving.. The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A report field is selected for the report when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following data fields.

Field Description

Employee When this field is checked the name of the employee having training leave
will be printed on the report.

Badge When this field is checked the badge number of the employee having the
training leave will be printed on the report.

Reason When this field is checked the reason for the training leave will be printed
on the report.

Start Date When this field is checked the starting date for the training leave will be
printed on the report.

End Date When this field is checked the ending date for the training leave will be
printed on the report.

Start Time When this field is checked the starting time for the training leave will be
printed on the report.

End Time When this field is checked the ending time for the training leave will be
printed on the report.

Description When this field is checked the description of the training leave will be
printed on the report.

Sort Order
Selection

The sort order selection for the report allows the following sort order selections:

n Employee - Employee Name

n Date - Starting date of the training

n Reason - Training reason
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Reason Selection To choose training reasons for the report select the Select Reasons object a list of all

defined reasons will appear as follows:

The reasons are selected by clicking on the desired reason with the mouse once, this

reason will now be highlighted. Any number of reasons may be selected by repeating

this procedure.

When all the desired reasons are selected press the OK button.

To de-select a single reason simply click on the highlighted reason and it will no

longer be selected. To de-select all the selected reasons select the Clear Reasons

option in the file menu.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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Other Leave Report

The Other Leave Report option prints a listing of the other leave reasons for each

employee.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the reasons to include or

exclude in the report.

If a single employeewas selected before running this program only that employeewill

be printed. The employee name will be shown after the report name at the top of the

window when a single employee has been selected

The dialog box for the Other Leave Report option in the reports menu appears as

follows:
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Saving.. The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

A report field is selected for the report when the box to the left of the field has a check

mark.

The report field selection for the report allows for the inclusion of the following data

fields.

Field Description

Employee When this field is checked the name of the employee having the other
leave will be printed on the report.

Badge When this field is check the badge number of the employee having the
other leave will be printed on the report.

Reason When this field is checked the other leave reason will be printed on the
report.

Start Date When this field is checked the starting date for the other leave will be
printed on the report.

End Date When this field is checked the ending date for the other leave will be
printed on the report.

Start Time When this field is checked the starting time for the other leave will be
printed on the report.

End Time When this field is checked the ending time for the other leave will be
printed on the report.

Description When this field is checked the description for the other leave will be printed
on the report.

Sort Order
Selection

The sort order selection for the report allows the following sort order selections:

n Employee - Employee name

n Date - Starting date of the other leave

n Reason - Other leave reason
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Reason Selection To choose other leave reasons for the report select theSelectReasons object a list of all

defined reasons will appear as follows:

Leave Report option in the reports menu appears as follows:The reasons are selected

by clicking on the desired reason with the mouse once, this reason will now be

highlighted. Any number of reasons may be selected by repeating this procedure.

When all the desired reasons are selected press the OK button.

To de-select a single reason simply click on the highlighted reason and it will no

longer be selected. To de-select all the selected reasons select the Clear Reasons

option in the file menu.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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All Leave Report

The All Leave Report option prints a listing of the All Leave reasons for each

employee.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the reasons to include or

exclude in the report.

If a single employeewas selected before running this program only that employeewill

be printed. The employee name will be shown after the report name at the top of the

window when a single employee has been selected.

The dialog box for the All Leave Report appears as follows:

Saving.. The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.

Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Field
Selection

The report field selection for the report allows for the inclusion of the following data

fields.

Field Description

Employee When this field is checked the name of the employee having the leave will
be printed on the report.

Badge When this field is checked the badge number of the employee having the
leave will be printed on the report.

Reason When this field is checked the reason for the leave will be printed on the
report.

Start Date When this field is checked the starting date for the leave will be printed on
the report.

End Date When this field is checked the ending date for the leave will be printed on
the report.

Start Time When this field is checked the starting time for the leave will be printed on
the report.

End Time When this field is checked the ending time for the leave will be printed on
the report.

Description When this field is checked the description for the leave will be printed on
the report.
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Sort Order
Selection

The sort order selection for the report allows the following sort order selections:

n Employee - Employee name

n Date - Starting date of the leave

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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Master File Reports

TheMaster Files Reports menu from the menu bar is used to print reports from the

schedule data.

TheMaster File Reports menu appears as follows:

F Master File Reports

n Employee Name and Address

n Employee Address Labels

n Shift Table Report

n Rotation Table Report

n Position Table Report

n Calendar Report

n Availability Report
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Name and Address Report

The Name and Address report option prints a listing of the Employee name and

addresses.

This function allows the user to select the data fields to include in the report, the name

and address layout, and to select a single employee for the report.

The dialog box for theName&Address Report option in the report menu appears as

follows:

Saving... The selections made by the user can be saved by selecting the Save Parameters in the

File menu.
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Report Fields
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following 25 data fields:

Field Description

Name When this field is checked the name of the employee in the name and address report will be printed.

Surname When this field is checked the surname of the employee in the name and address report will be
printed.

Given Name When this field is checked the given name of the employee in the name and address report will be
printed.

Start Date When this field is checked the starting date of the name and address report will be printed.

End Date When this field is checked the ending date of the name and address report will be printed.

Medical When this field is checked the medical of the name and address report will be printed.

Family Med. When this field is checked the family med. of the name and address report will be printed.

Home Phone When this field is checked the home phone number of the name and address report will be printed.

Address 1 When this field is checked the address 1 of the name and address report will be printed.

Address 2 When this field is checked the address 2 of the name and address report will be printed.

City When this field is checked the city of the name and address report will be printed.

Province When this field is checked the province of the name and address report will be printed.

Postal Code When this field is checked the postal code of the name and address report will be printed.

Department When this field is checked the department of the name and address report will be printed.

Account When this field is checked the account of the name and address report will be printed.

Sub Account When this field is checked the sub account of the name and address report will be printed.

Alt. Phone When this field is checked the alt.phone of the name and address report will be printed.

Badge When this field is checked the badge number of the name and address report will be printed.

Number When this field is checked the number of the name and address report will be printed.

S.I.N. When this field is checked the S.I.N. of the name and address report will be printed.

Sex When this field is checked the sex of the name and address report will be printed.

Position When this field is checked the position of the name and address report will be printed.

Treaty When this field is checked the treaty of the name and address report will be printed.

Band When this field is checked the band of the name and address report will be printed.
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Layout 1
Selection

The dialog box for the name and address report layout appears as follows:

Defaults The default selections can be re-displayed by selecting the default selections in the file

menu. If you wish to always use the defaults select the Save Parameter option in the

File menu.
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Layout 2
Selection

The second dialog box for the name and address report layout appears as follows:

Defaults The default selections can be re-displayed by selecting the default selections in the file

menu. If you wish to always use the defaults select the Save Parameter option in the

File menu.
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In order to design a report layout you must specify the following 3 things:

n Off-Set

n Column

n Field Length

Off-Set This is the line offset used for printing the name and address information. Eg) If you

want this field to print on the first line of this name and address information use an

off-set of zero. If it is to follow on the second line use an off-set of 1. Youmay have as

many off-sets as you need to print all the fields you have selected.

Column This is the character position on the print line for the name and address information.

Eg) If the field is to start 5 spaces in from the left hand margin enter a 6 in the column

field. The column numbers are only limited by the number of characters you can print

on each line of your selection page.

Field Length This is the number of characters that make up the field. Eg) Employee number is 10

characters long. If you want to see the entire employee number enter 10 in the field

length. If you are doing the date which is 10 characters you may choose to print only

the last 5 giving you mm/dd. The date field is the only field that takes the characters

from the right hand side.
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Sizes Selection The following dialog box for the name and address report appears as follows:
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Select Report
Selection

The dialog box for the name and address report appears as follows:

Single Employee
Option

To choose a single employee option for the Name andAddress report select the Single

Employee object.

For instructions on how to select a single employee option refer to page 13 of the

common selection screen chapter.

This report allows you the option to print each employee on a separate page. Select the

page break yes field. When this is selected the box to the left of the field has a check

mark.
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Name and Address Label

The Name & Address Label option prints an employee name and address label.

This function allows the user to select the data fields to include in the label, the name

and address layout, and to set up the label layout.

The dialog box for the Name & Address Label option in the report menu appears as

follows:

Saving... The selections made by the user can be saved by selecting the Save Parameters in

the File menu.
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Report Fields
Selection

A data field is selected for the label when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following 25 data fields:

Field Description

Name When this field is checked the name of the employee in the name and address label will be printed.

Surname When this field is checked the surname of the employee in the name and address label will be
printed.

Given Name When this field is checked the given name of the employee in the name and address label will be
printed.

Start Date When this field is checked the starting date of the name and address label will be printed.

End Date When this field is checked the ending date of the name and address label will be printed.

Medical When this field is checked the medical of the name and address label will be printed.

Family Med. When this field is checked the family med. of the name and address label will be printed.

Home Phone When this field is checked the home phone number of the name and address label will be printed.

Address 1 When this field is checked the address 1 of the name and address label will be printed.

Address 2 When this field is checked the address 2 of the name and address label will be printed.

City When this field is checked the city of the name and address label will be printed.

Province When this field is checked the province of the name and address label will be printed.

Postal Code When this field is checked the postal code of the name and address label will be printed.

Department When this field is checked the department of the name and address label will be printed.

Account When this field is checked the account of the name and address label will be printed.

Sub Account When this field is checked the sub account of the name and address label will be printed.

Alt. Phone When this field is checked the alt.phone of the name and address label will be printed.

Badge When this field is checked the badge number of the name and address label will be printed.

Number When this field is checked the number of the name and address label will be printed.

S.I.N. When this field is checked the S.I.N. of the name and address label will be printed.

Sex When this field is checked the sex of the name and address label will be printed.

Position When this field is checked the position of the name and address label will be printed.

Treaty When this field is checked the treaty of the name and address label will be printed.

Band When this field is checked the band of the name and address label will be printed.
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Layout 1
Selection

The second dialog box for the name and address label layout appears as follows:

Defaults The default selections can be re-displayed by selecting the default selections in the file

menu. If you wish to always use the defaults select the Save Parameter option in the

File menu.
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Layout 2
Selection

The second dialog box for the name and address label layout appears as follows:

Defaults The default selections can be re-displayed by selecting the default selections in the file

menu. If you wish to always use the defaults select the Save Parameter option in the

File menu.
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In order to design a label layout you must specify the following 3 things:

n Off-Set

n Column

n Field Length

Off-Set This is the line offset used for printing the name and address information. Eg) If you

want this field to print on the first line of this name and address information use an

off-set of zero. If it is to follow on the second line use an off-set of 1. Youmay have as

many off-sets as you need to print all the fields you have selected.

Column This is the character position on the print line for the name and address information.

Eg) If the field is to start 5 spaces in from the left hand margin enter a 6 in the column

field. The column numbers are only limited by the number of characters you can print

on each line of your selection page.

Field Length This is the number of characters that make up the field. Eg) Employee number is 10

characters long. If you want to see the entire employee number enter 10 in the field

length. If you are doing the date which is 10 characters you may choose to print only

the last 5 giving you mm/dd. The date field is the only field that takes the characters

from the right hand side.
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Sizes Selection The following dialog box for the name and address label appears as follows:
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Label Selection The following dialog box for the label appears as follows:

In laying out the label the other things the program needs to know is:

1. The number of lines your label will hold.  A standard label is 8 lines long.

2. The line the label information will start on.  This means that after the heading
fields are printed the label information will start on the line number.

F Label Legend - You can specify if the legend will be printed above or to the left of the
label information.

Print Sample
Label

This will print a sample label for you to verify the line up of your label.
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Shift Table Report

The Shift Table Report prints a listing of the shift control information. This function

allows the user to select the date range for the report.

The dialog box for the Shift Table Report option in the Master File Report menu

appears as follows:

Date Range
Selection

To limit the range of the report the starting and ending date may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Field Description

Shift Code This field is the shift code.

Shift Description This field is used to show the description of the shift code.

Start Date This field is the starting date of the shift table information.

Ending Date This field is the ending date of the shift table information.

Earning Table Code If an earning table is entered the earning code for the table will be
printed or the word NONE will appear if no earning table code has been
specified.

Start Time This field is the starting time of the shift.

End Time This field is the ending time of the shift.

Break Number This field is used to determine the break number.

Break Start This field is used to determine the starting time of the break.

Break Length This field is used to determine the length of the break.

F You may specify up to 7 breaks per shift.
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Rotation Table

The Rotation Table Report option prints a listing of the rotation patterns. This

function allows the user to select the date range for the report.

The dialog box for theRotationTableReport option in theMaster File Reportsmenu

appears as follows:

Date Range
Selection

To limit the range of the report the starting and ending date may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Fields

Field Description

Rotation Code This field is the rotation code of the rotation pattern.

Rotation Description This field is used to show the description of the rotation code.

Start Date This field is the starting date for the rotation pattern.

Stop Date This field is the stopping date for the rotation pattern.

Rotation Day This field is the day number for the rotation table information.

Rotation Shift This field is the shift code name used for the rotation table
information.

F You may have up to 400 rotation days set up in the rotation table for each rotation
code.  Each rotation day may have up to 5 user defined shifts.
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Position Table Report

The Position Table Report option prints a listing of Position Information.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the object to include or

exclude in the report.

If a single position was selected before running this program only that position will be

printed. The name of the position will be shown after the report name at the top of the

windowwhen a single position has been selected. TheSelect Positions optionwill not

be available when a single position has been selected.

The dialog box for the Position Table Report option in the Reports menu appears as

follows:

Saving... The selections made by the user can be saved by selecting the Save Parameters in the

File menu.
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Date Range
Selection

To limit the range of the report youmay enter the starting and ending date. If both dates

are zero the entire report will be printed. If only the ending date is zero both the report

will be printed from the starting date until the end of the report.

Report Fields
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The report field selection allows for the inclusion of the following nine data fields.

Field Description

Position When this field is checked the position will be printed on the report.

Description When this field is checked the description of the position will be printed on the
report.

Type When this field is checked the position type code will be printed on the report.

Class When this field is checked the position class code will be printed on the report.

Start Date When this field is checked the starting date of the position will be printed on
the report.

End Date When this field is checked the ending date of the position will be printed on the
report.

Pay Table When this field is checked the pay table will be printed on the report.

Distribution When this field is checked the distribution will be printed on the report.

Hour

Allocation

When this field is checked the position hour allocation will be printed on the
report.

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections:

n Position Code - User Defined Code

n Position Description - User Defined Description
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Select Positions
Selection

To choose selected positions for the Position Assignment Report select the Select

Positions object.

For instructions on how to select positions refer to page 9 of the common selection

screen chapter.

If you have selected positions the message Exclude Selections or Include Selections

will be displayed beside the selection buttonwhen you return to the select report object

dialog box.

Description Field
Selection

The description field selection for the report allows for the following field options:

n Full Description - Entire description entered

n First Paragraph - First paragraph entered

The description area can be up 8,000 characters and youmay not want to see the entire

description printed in all cases. If you select the First Paragraph option in the report

it will print all the description information up to the first time you pressed the ENTER

key.
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Calendar Table Report

TheCalendar Table Report prints a listing of the calendar holiday information. This

function allows the user to select the date range for the report.

The dialog box for the Calander Table Report option in the Master File Reports

menu appears as follows:

Date Range
Selection

To limit the range of the report the starting and ending date may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Report Fields
Field Description

Calendar Date This field contains the calendar date.

Statutory Holiday This field contains the message statutory if it is a statutory holiday.

Calendar Holiday This field contains the message calendar holiday if it is a calendar
holiday.

Description This field contains the user defined description of the calendar holiday
when available.

Included This field is a list of user defined codes to be included.

Excluded This field is a list of user defined codes to be excluded.

F The user defined codes allows up to 100 characters these codes are used in schedule
generation to determine if the calendar date is included or excluded.
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Availability Report

TheAvailability Report prints a listing of the available time for each employee. This

function allows the user to select the date range for the report.

The dialog box for theAvailabilityReport option in theMaster File Report appears as

follows:

Date Range
Selection

To limit the range of the report the starting and ending datemay be entered if both dates

are zero the entire report will be printed. If only the ending date is zero the report will

print from the starting date until the end of the report.
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Report Fields
Fields Description

Employee Name This field is the name of the employee

Start Date This field is the starting date of this availability information.

End Date This field is the ending date of this availability information.

Weeks The number of weeks in the cycle is entered in this field.

Week-1 This field is used to show the day number of the week when an employee is
available to work in week one.

Week-2 This field is used to show the day number of the week when an employee is
available to work in week two.

Week-3 This field is used to show the day number of the week when an employee is
available to work in week three.

Week-4 This field is used to show the day number of the week when an employee is
available to work in week four.

Available Hours This field is used to show the number of hours the employee is available to
work in the week.

Day of Week This field is the day of week specified by the day number.

Starting Time This field is the starting time that the employee is available on this day

Ending Time This field is the ending time that the employee is available on this day.

Preferred Days This field is used to show the day number of the week that an employee
prefers to work.

Preferred Hours This field is used to show the number of hours the employee prefers to
work in the week.

Starting Time This field is the starting time the employee prefers to work.

Ending Time This field is the ending time the employee prefers to work.
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Custom Reports

The Grand Master Suite Custom Reports module provides a report definition

function and a Report Generation function. These two functions allow the user to

define and print reports that includes data from the system defined database and the

user defined database.

Please refer to page of the custom reports chapter for more information on custom

reports.
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HOMECARE

The GrandMaster Suite Homecare Module is a separately installed product. The

module adds additional functionality to the GrandMaster Suite Schedule Module.

The added functionality allows the user to prepare master schedules for homecare

clients, generate detailed schedule items for homecare clients and prepare homecare

schedule reports.
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Installation

The Homecare module is a separate add-on module for the GrandMaster Schedule

Module. As such, it has a separate distribution disk and installation procedure.

F The Homecare module should be installed AFTERthe GrandMaster Schedule
Module is installed.

Windows Installation

GrandMaster SuiteHomecare utilizes the standardwindows setup program. Windows

3.1x must be operational.

The following steps will take you through the installation:

1. Insert the disk labeled “GrandMaster Suite Homecare Setup” into the diskette
drive.

2. From the program manager selectRun option from the File menu.

3. Enter A:\SETUP into the command line field and click on theOK BUTTON.

A window will appear indicating that the GrandMaster Suite Homecare installation

program is being initialized. The window will appear as follows:
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After the initialization process completes, the dialog box below will appear which

allows the user to continue with the installation, or exit from the install process.

4. Press theCONTINUE button to proceed with the installation.

The �Installation Directory for GrandMaster Suite Homecare� dialog box, shown

below, is used to determine the root directory for GrandMaster Suite Homecare on

your hard drive. The default is C:\GMSUITE.

5. Enter the directory that you used to install GrandMaster Suite and select the
CONTINUE button.
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The following screen will appear as the installation continues:

This screen will disappear when the installation has finished.

If the installation was completed successfully the following screen will appear

indicating the installation was successful:

6. Select theOK button to exit the installation process.
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GrandMaster Suite Homecare

The GrandMaster Suite Homecare Module is an extension to the GrandMaster Suite

Schedule Module.

The Homecare sub menu from the Schedule menu appears as follows:

The Homecare Module adds the following functions to the main schedule menu.

n Client Activity Schedule - This function is used to define the schedule of
services for a client.

n Client Master Schedule - This function is used to define the master schedule of
services for a client.

n Employee Activity Schedule - This function is used to access the client
activities by assigned employee.

n Locate Unallocated Calls - This function is used to locate client services that
have not been allocated to an employee.

n Cancel Homecare Call - This function is used to cancel homecare calls for a
client within a date range.

n Generate Detail Schedule - This function is used to generate the detail
Homecare Schedule items from the client schedule of services.

n Delete Detail Schedule - This function is used to delete portions of the detail
Homecare Schedule.

n Area Seniority List Update - This function is used to update the seniority list to
be assigned to the area code.

n Update Client Master - This function is used to access the homecare client
update.
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The Homecare sub menu from the Reports menu appears as follows:

The Homecare Module also provides additional functionality for the Schedule

Module functions.

When a schedule item is generated from the homecare activity schedule the daily

employee schedule, weekly employee schedule, and the employee detail schedule

functions will present the client name as well as the other schedule detail fields.

The Employee Detail Schedule report allows an additional field to print the client

name on the Schedule Report.
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The Homecare Module adds the following report functions to the Schedule Report

menu.

n Homecare Employee Worksheet - This report presents an employees' schedule
of homecare calls with the days of the month as rows and the time of day as
columns. The client name and activity for the calls scheduled are printed in the
appropriate row and column.

n Homecare Employee Week - This report prints the activity times slots with
(clients names) for the employee for a given week.

n Homecare Employee Month - This report prints the activity, time slots with
clients names for the employee in a calendar format for a given month.

n Homecare Employee Seniority - This report prints the area code and up to six
seniority lists for each area. The report on request will show the detail on the
seniority lists showing the employees in seniority order.

n Homecare Client Worksheet - The report presents a client's schedule of
homecare calls with the days of the month as rows and the time of day as
columns. The employee name and activity for the calls scheduled are printed in
the appropriate row and column.

n Homecare Client List - The report presents a listing of the details on homecare
clients including and the service scheduled for the client, with the employee
assignments.

n Homecare Client Schedule - This report prints the detail information for each
homecare schedule item for that client in the given date range.

n Homecare Client Week - This report prints the activity, time slots with assigned
employees for the client in a given week.

n Homecare Client Month - This report prints the activity time slots in the
assigned employees for the client in a calendar format for a given month.
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Client Activity Schedule

The Client Activity Schedule option allows the user to enter in all the activities

required by the client and to assign employees to the activities.

This option first prompts the user for the name of the client for which to schedule

activities. The dialog box will appear as follows:

The following fields appear in the dialog box:

Field Description

Client The client field is used to select a client by typing in the client's name

Address The address of the client will appear below the client field after a client has
been selected - no changes can be made to this information in this screen.

Phone The phone number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Medicare The medicare number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Account The account number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Locale The area of the client's home will appear in this field. This field is for display
only - no changes can be made to this information in this screen.

Client Node This is the internal reference number for the client information.
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OK The OK button will save any changes made in the dialog box.

Esc (exit) The ESC key, CANCEL button, or Exit option from the File menu will exit the dialog

box without saving any changes.

Next Client The NEXT CLIENT button calls up the next client, in name order.

Prior Client The PRIOR CLIENT button calls up the prior client, in name order.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of client names

fromwhich the user can select a client. From the dialog box containing the list the user

can also insert, update, or delete clients from the list. For more information about this

dialog box please see the �Update Client Master� section in this manual.
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Client Requirements

Once a client has been selected, in the Client Activity Schedule option, the following

screen will appear in which the user can set up activity schedules for the selected

client:

The GrandMaster Homecare Schedule module supports multiple activity schedules

for each client.
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The following fields appear in the dialog box:

Field Description

Client The client name will be displayed.

Address The client address will be displayed.

Phone The client telephone number will be displayed.

Locale The homecare district code and description will be displayed.

Services list The list contains the activities established for the client that have to be
scheduled and assigned employees. The list shows the activity, position, start
date, end date and position description.

Set Date Range The Set Date Range option from the File menu is used to change the date range.

Esc (exit) The ESC key, the EXIT button, or the Exit option from the File menu will exit from the

screen without saving any changes.

Insert The INSERT button will allow the user to insert a new activity schedule in the services

list.

Additional The ADDITIONAL button makes a copy of the selected activity and allows the user to

update the copy.

Update The UPDATE button will allow the user to update any existing activity schedules in

the services list.

Delete The DELETE button will allow the user to delete any activity schedules from the

services list.
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Entering Client Requirements

To insert new activities required by the client do the following:

1. Select theClient Activity Scheduleoption and choose a client when the Home
Care Client Selection dialog box appears.

2. The Home Care Client Requirements dialog box will appear, select theINSERT

button.  A dialog box will appear as follows:

3. Enter the required information into the dialog box and select theOK button.

Each activity schedule defines the position class and activity code that is used for the

scheduled items.
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The following fields appear in the dialog box:

Field Description

Client The client name will be displayed.

Start Date The start date is used to determine the earliest date for scheduling an activity.
An activity must always have a start date. The schedule generation process
uses the start date to control the creation of schedule items for the activity.

End Date The end date is used to determine the latest date for scheduling an activity. An
end date of zero indicates that the activity may be scheduled for an unlimited
number of days into the future. The schedule generation process uses the end
date to control the creation of schedule items for the activity.

Essential

Service

This flag will be checked if this service is required on statutory holidays.

Position The position class is used to determine the pay rates and description for the
employee(s) assigned to the client schedule.

Activity The activity code is used to classify the time and description for billing the
time to the Homecare client.

Monthly When this field is checked the rotation is monthly.

Number of

Employees

This field indicates the number of employees to be assigned to the activity.

Weeks to

Schedule

This field indicates the number of weeks to use when generating the detail
schedule items can be from 1 to 6.

Daily Schedule

Slots

Each notebook page contains up to three schedule slots per day for the activity.
The starting time and ending time entered should be in a 24 hour clock format.
Up to 6 weeks rotation can be setup.

ID This field contains the internal client ID number.

F When the end date of an activity is changed the system will delete any schedule items
that extend past the new end date.

F When the start date of an activity is changed the system will delete any schedule items
that occur prior to the new start date.

F If the scheduled items to delete have been processed by the Time keeping function a
warning message will be issued, the schedule items will be left on file, and an
exception report will be generated.

Each activity may define a rotation pattern for service times that may be up to six

weeks in length. This rotation pattern is used to generate the schedule items for the

client.

Each notebook page contains up to three schedule slots per day for the activity. If an

activity must be scheduled more than three times per day another activity schedule

may be created that overlaps the first activity date range.

List The List option from the File menu will bring up a list of the positions or activities

available depending on which field contains the cursor.
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Save The Save option from the File menu will save any changes made to the screen.

Generate
Schedule

The Generate Schedule option from the File menu will generate the schedule.

Exit TheExitoption from theFilemenuwill exit the screenwithout saving any changes.
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Employee Assignments

To assign employees to the client activities select the EMPLOYEEASSIGNMENTbutton

within the Home Care Services dialog box.

The following dialog box will appear:

This dialog box will list all the employees assigned, and their start and end date.

Insert The INSERT button will allow the user to add a new employee into the employee

assignments list for the client activity.

Update TheUPDATE buttonwill allow the user to update an employee that already exists in the

employee assignments list for the client activity.

Delete The DELETE button will allow the user to remove an employee from the employee

assignments list.

Exit TheESCkey, or theEXITbutton from theFilemenuwill exit the screenwithout saving.
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Inserting an Employee

Select the INSERT button to add an employee to the Employee Assignments list. The

following screen will appear:

The following table contains a description of the fields in the above dialog box:

Field Description

Employee This field contains the employee name.

Start Date This field is used to determine the earliest date that the employee will
be assigned homecare calls for this activity. A date of zero indicates
that the activity start date is used.

End Date This field is used to determine the latest date that the employee will be
assigned homecare calls for this activity.

Start Time This field is used to determine the earliest time of day that the
employee will be assigned homecare calls for this activity.

End Time This field is used to determine the latest time of day that the employee
will be assigned homecare calls for this activity.

Days of the Week This field is used to determine the days of the week that the employee
will be assigned homecare calls for this activity. The days are from
Sunday (1) to Saturday (7).

F8 (list) The F8 key, or the List option from the File menuwill, when the cursor is placed in the

Name field, bring up a list of client names from which the user can select a client.

OK The OK button will confirm the choice of the client and display the list of activities

scheduled for the client

Esc (exit) The ESCkey,CANCELbutton, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Client Master Schedule

TheClientMaster Schedule option allows the user to enter in all themaster activities

required by the client and to assign employees to the activities.

The master schedule allows the following enhancements to the regular client activity

schedule feature:

n multiple activities for a given time slot

n up to eight slots per date rather than 3 at a time

n allows you to use the on call person rather than an open assignment by seniority

n allows an activity to occur within a time slot duration rather than at a specific
start and stop time

This option first prompts the user for the name of the client for which to schedule

activities. The dialog box will appear as follows:

The following fields appear in the dialog box:

Field Description

Client The client field is used to select a client by typing in the client's name

Address The address of the client will appear below the client field after a client has
been selected - no changes can be made to this information in this screen.

Phone The phone number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Medicare The medicare number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Account The account number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.
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Field Description

Locale The area of the client's home will appear in this field. This field is for display
only - no changes can be made to this information in this screen.

Client Node This is the internal reference number for the client information.

OK The OK button will save any changes made in the dialog box.

Esc (exit) The ESC key, CANCEL button, or Exit option from the File menu will exit the dialog

box without saving any changes.

Next Client The NEXT CLIENT button calls up the next client, in name order.

Prior Client The PRIOR CLIENT button calls up the prior client, in name order.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of client names

fromwhich the user can select a client. From the dialog box containing the list the user

can also insert, update, or delete clients from the list. For more information about this

dialog box please see the �Update Client Master� section in this manual.
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Once you have selected the desired client the Client Activity Master Schedule screen

will appear:

The following fields appear in the dialog box:

Field Description

Start D ate This field contains the starting date of the schedule.

End Date This field contains the ending data of the schedule.

Weekly When this field is checked the schedule is weekly.

Monthly When this field is checked the schedule is monthly.

Weeks This field contains the number of weeks in the schedule.

You may click on the desired week and enter up to 8 time slots per day.
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If you click on the activity button you will see the Activity Assignment screen.

You may enter the following fields for a given activity.

Fields Description

Activity This field contains the activity code of the assignment.

Position This field contains the position code of the assignment.

Hours This field contains the hours for the activity. The time slot will be displayed
beside the hours.

You have the following option on selecting the employee:

n Select Employee (pick the employee you want)

n Employee on Shift (use the on call employee)

Under the date action menu item you may do the following

n Time slot assignments

n Delete slot assignments

n delete day assignments

n copy slot (from a slot to a slot)

n Copy day (from a day to a day)
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Employee Activity Schedule

The Employee Activity Schedule option provides a method for accessing the client

activity master schedule records that are assigned to a particular employee.

The option allows the user to insert new employee assignments, update existing

employee assignments, and delete existing employee assignments.

The option first requests the employee. This selection uses the standard employee

selection screen as follows:

When you choose to insert, add or delete the activity assignment you will be taken to

the Client Activity Schedule. For more information on how to schedule clients and

activities turn to the Client Activity Schedule section.

Search Technique The Search Technique option in the File menu allows the user to set the manner in

which the employees should be located. There are three ways to search the employee

list: by name, by employee number, or by badge number. See the section on Setting

Search Technique from the File menu for further information.

Next Employee The NEXT button, or the Next Employee option from the File menu will move to the

next employee in the list.

Previous
Employee

The PREVIOUS button, or the Previous Employee option from the File menu will

move to the previous employee in the list.

F8 (list) The F8 key, or theList Employees option from the File menu will bring up a list of the

employees. The employees within the list will depend on whether or not an employee

group has been selected (see the section on managing employee groups from the File

menu for further information). The order of the employees in the list will depend on

the type of search technique that has been set.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Employee Activities

After the employee is selected the option presents a list of the employee's assignments

that fall within the default date range.

The screen contains the following data fields:

Field Description

Employee This field contains the employees name and address.

Phone Number This field contains the employees phone number.

Client List The list contains the activity, the starting and ending date,
client name, position code and description.

F The date range can be changed using theSet Date Rangeoption under the File menu.

Insert The INSERT button allows the user to establish a relationship between the selected

employee and a client activity.

Additional The ADDITIONAL button allows the user to establish another assignment between the

selected employee and the client activity under the selection bar.

Update TheUPDATEbutton allows the user to update the client activity under the selection bar.

Delete The DELETE button allows the user to delete the assignment to the activity under the

selection bar.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Locate Unallocated Calls

TheLocate Unallocated Calls option is used to find Homecare Schedule detail items

that do not have an employee assignment.

When the Locate Unallocated Calls option is selected the following screen will

appear:

The Homecare Unallocated Calls dialog box contains the following fields:

Field Description

Start Date This field contains the starting date of your date range.

Ending Date This field contains the ending date of your date range.

Client This field contains the name of the client for which to find the unallocated
calls.

Homecare Schedule detail items may lack an employee assignment for a number of

reasons.

n No employee is assigned to the client activity

n The assigned employee is on vacation, sick leave, or is absent for some other
reason.

n During schedule generation the assigned employee has a schedule conflict with
another scheduled activity.
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The Locate Unallocated Calls function allows an employee to be assigned to a

schedule detail item. This assignment does not affect the employee assignment list for

the client activity schedule.

When the missing employee assignment is a result of scheduled leave the function

uses the standard schedule replacement functions.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of the clients.

Locate Items The LOCATE ITEMS button, or theLocate Items option from the File menu will locate

any unallocated calls for the current client.

Next Client The NEXT CLIENT button, or the Next Client option from the File menu will move to

the next client in the client list.

Previous Client The PREVIOUSCLIENT button, or the Previous Client option from the File menu will

move to the previous client in the client list.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Locate Items

When the LOCATE ITEMS button is selected, in the Homecare Unallocated Calls dialog

box, the system will begin the generation of a list of all unallocated calls within the

specified date range. The list will appear similar to the following:

The following table gives a description of the fields within the screen:

Field Description

Client The client's name and client ID. For display only.

Start Date The start date of your date range. For display only.

Ending Date The ending date of your date range. For display only.

Unallocated Call

Items List

This list contains all the unallocated call items within the date range. The
columns from left to right are: shift, date, client, start time, stop time, and
area.
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Update Item TheUPDATEITEMbutton, or double clicking on the item in the listwill allow the user to

update the schedule item highlighted by the selection bar. When the update item

button is pressed the following screen will appear:

The following table gives a description of the fields within the screen:

Field Description

Client This field contains the client's name for the schedule item.

Employee This field contains the employees name for the schedule item.

Date This field contains the date for the schedule item.

Shift This field contains the shift code for the schedule item.

Premiums This field contains the premium code for the schedule item.

Start Time This field contains the starting time for the schedule item.

End Time This field contains the ending time for the schedule item.

Hours This field contains the hours for the schedule item.

Reason This field contains the reason code for the schedule item.

Position This field contains the position code for the schedule item.

Area This field contains the area code for the schedule item.

Sub Area This field contains the sub area code for the schedule item.

Activity This field contains the activity code for the schedule item.

Sub Activity This field contains the sub activity code for the schedule item.

G/L Code This field contains the G/L code for the schedule item.
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Cancel Homecare Calls

The Cancel Homecare Calls option is used to mark homecare calls as canceled.

When a call is canceled the employee assigned to the call may be assigned to another

call without a schedule conflict.

Cancellations may be entered for a date range and may specify a start time and stop

time range.

The following screenwill appearwhen theCancelHomecareCalls option is selected:

The following table gives a description of the fields within the screen:

Field Description

Date From This field contains the starting date.

Date To This field contains the ending date.

Cancellations This field contains a list of cancellations.

Set Date Range The Set Date Range option in the File menu will allow the user to change the date

range.

Insert The INSERT button, or the Insert Item option in the File menu allows the user to add a

new cancellation for any client to the cancellation list.

Additional The ADDITIONAL button, or the Additional for Employee option in the File menu

allows the user to add additional cancellations for the client currently under the

selection bar.
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Update The UPDATE button or the Update Entry option in the File menu allows the user to

update the currently selected cancellation in the cancellation list. The update screen

appears as follows:

The fields requiring input are as follows:

Field Description

Start Date Starting date for a date range for canceling calls.

End Date Ending date for the cancellation date range.

Start Time Starting time for a time range for canceling calls.

End Time Ending time for the cancellation time range.

Reason This field is used to enter the reason code for the cancellation. Selecting the F8

key, or the List option from the File menu will bring up a list of reasons when
the cursor is placed in the reason field.

Description This field can be used to enter a description for the cancellation.

Delete The DELETE button, or the Delete Entry option from the File menu will remove the

item selected by the selection bar.

Esc (exit) The ESC key, the EXIT button, or theExit option from the Filemenuwill exit the screen

without saving any changes.
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Generate Detail Schedule

TheGenerateDetail Schedule option creates the detail schedule items from the client

activity schedule data and the associated employee assignments.

When the Generate Detail Schedule option is selected the following screen will

appear:

The dialog box contains the following fields:

Field Description

Area The area for which to generate a detail schedule. If this field is left blank the
schedule will be generated for all areas. When a client is selected, the area of
the client is automatically entered in the area field.

Client The client for which to generate a detail schedule.

Position The position for which to generate a detail schedule. A client must be selected
before a position can be entered. If this field is left blank the schedule will be
generated for all positions of the client.

Start The starting date of the date range for schedule generation.

End The ending date of the date range for schedule generation.

Delete Before

Generation

This check box forces the deletion of any previously generated detail items.
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The function will attempt to allocate the associated employees according to the day of

theweek and time of day limits set on the employee association. The function tests for

a conflict with any other time scheduled for an employee before assigning the

employee to the call.

When no associated employee can be allocated the call is createdwithout an employee

assigned the locate unallocated calls function is used to assign employees to calls on an

ad hoc basis.

The generate detail schedule function allows the user to select individual areas, clients,

or client activities to limit the schedule detail generation.

After the detail schedule is generated any employee leave time scheduled is applied to

the detail schedule item.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of information

corresponding to the field in which the cursor is placed. The fields which will have a

list available are area, client, and position.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

screen without saving any changes.

Generate The GENERATE button will begin the generation of the detail schedule.
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Delete Detail Schedule

The Delete Detail Schedule option is used to delete detail schedule items.

When theDeleteDetail Schedule option is selected the following screenwill appear:

The dialog box contains the following fields:

Field Description

Area The area for which to delete a detail schedule. If this field is left blank the
schedule will be detected for all areas. When a client is selected, the area of
the client is automatically entered in the area field.

Client The client for which to delete a detail schedule.

Position The position for which to delete a detail schedule. A client must be selected
before a position can be entered. If this field is left blank the schedule will be
deleted for all positions of the client.

Start The starting date of the date range for schedule deletion.

End The ending date of the date range for schedule deletion.
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The option allows the user to select individual areas clients or client activities to limit

the schedule items deleted.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of information

corresponding to the field in which the cursor is placed. The fields which will have a

list available are area, client, and position.

Esc (exit) The ESC key, the CANCEL button, or the Exit option from the File menu will exit the

screen without saving any changes.

Delete The Delete button will begin the deletion of the detail schedule.
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Area Seniority Update

The area seniority update allows you to set up seniority lists for a given area, or the

master seniority list if no area has been specified.

The option first requests the area for the seniority list.

F8 (list) The F8 key or the list option from the file menu will bring up a list of all the areas.

ESC TheESCkey, CANCELbutton, or Exit option in the Filemenuwill exit the dialog box

without saving any changes.

OK TheOKbutton or update from the filemenuwill allowyou to update the seniority list.
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After the area is selected the option presents a screen showing the area and description

with the ability to select 6 lists for this area.

F8 (List) TheF8 key or list option from the filemenuwill allowyou to select a seniority list from

the given list of available seniority lists.

ESC TheESCkey, CANCELbutton, or Exit option in the Filemenuwill exit the dialog box

without saving any changes.

OK The OK button or UPDATE option from the file menu will allow you to save your add

or changes to the seniority list.
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When you are selecting your seniority list from the list of seniority lists you may

update or change the lists.

Insert The INSERT button will allow you to add a new list.

Update The UPDATE button will allow you to update a list.

Delete The DELETE button will allow you to delete a list.

OK The OK button or CANCEL button will return you to the screen where you select

seniority lists for your area.
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The seniority list update shows you the employees or the seniority list.

The following dialog box allows the data fields to be input:

Field Description

Code This field contains the name of the seniority list.

Description This field contains a description of the seniority list code.

Effective Date From This field contains the date the list is effective from.

Effective Date To This field contains the date the list is effective to.

Seniority List This field shows the order, hours, and the employee name
starting with the employee with the most seniority.
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The update an employee double click on the line or on a new line for a newemployee to

be added.

The information required for a new employee to be added is the employee name,

number of hours and the order number.

The number of hours are the hours used to determine seniority.

The order field is used to enter the position number if several employees have the same

number of hours.
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Update Client Master

TheUpdate ClientMaster option allows the user to enter in new clients (through the

list option) and update existing clients master information. This information includes

address, ID, emergency, and notes.

When the Update Client Master option is selected the following dialog box will

appear:

The following fields appear in the dialog box:

Field Description

Client The client field is used to select an existing client to update by typing in the
client's name.

Address The address of the client will appear below the client field after a client has
been selected - no changes can be made to this information in this screen.

Phone The phone number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Medicare The medicare number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Account The account number of the client will appear in this field. This field is for
display only - no changes can be made to this information in this screen.

Locale The area of the client's home will appear in this field. This field is for display
only - no changes can be made to this information in this screen.

Client Node This is the internal client Id number.

OK The OK button will allow the user to update the master information entered for the

currently selected client.
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Esc (exit) The ESC key, CANCEL button, or Exit option from the File menu will exit the dialog

box.

Next Client The NEXT CLIENT button calls up the next client, in name order.

Prior Client The PRIOR CLIENT button calls up the prior client, in name order.

F8 (list) The F8 key, or the List option from the File menu will bring up a list of client names

from which the user can select a client.

The general information for the client selected with the selection bar will appear at the

bottom of the dialog box. General information includes address, ID, account, and

medicare number. From the dialog box containing the list the user can insert, update,

or delete clients from the list.
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Inserting New Clients

To insert a new client do the following:

1. Select theUpdate Client Masteroption in the Homecare sub menu.

2. In the Home Care Client Selection dialog box select theF8 key, or theList
option from the File menu.

3. When the Home Care Client List dialog box appears select theINSERTbutton.
The Homecare Client Data Screen dialog box will appear.  This dialog box
contains four tabs: address, ID, emergency, and notes (a description of each
screen is listed below).

4. Fill in the required data and select theOK button.

The Address screen appears as follows:

For each item on the list the following data fields may be input:

Field Description

Surname This field contains the surname of the client.

Given Name This field contains the given name.

Address 1 This field contains the address line 1 of the client.

Address 2 This field contains a line 2 address of the client.

City This field contains the city of the client.

Province This field contains the province of the client.

Postal Code This field contains the postal code of the client.

Area This field contains the area code that the client is located in.

Account This field contains the account number of the client.
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When the ID tab is chosen the following screen will appear:

For each item on the list the following data fields may be input.

Field Description

Birth Date This field contains the birth date of the client.

Sex This field contains the sex of the client.

S.I.N. This field contains the clients social insurance number.

Medical This field contains the medical number of the client.

Family Med This field contains the family medical number of the client.

Phone Number This field contains the phone number of the client.

Alt Phone This field contain an alternate phone number for the client.
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When the Emergency tab is chosen the following screen will appear:

For each item on the list the following data fields may be entered:

Field Description

Contact This field contains the name of the person to contact in case of an
emergency.

Relationship This field contains the relationship of the contact person in case of an
emergency,

Phone 1 This field contains the phone number of the person to contact in case of an
emergency.

Phone 2 This field contains an alternate phone number of the person to contact in
case of an emergency,

Physician This field contains the physician name for the client in case of the
emergency.

Phone number This field contains the phone number of the physician for the client in case
of emergency.

Physician This field contains the alternate physician name for the client in case of
emergency.

Phone Number This field contains the alternate phone number of the physician for the
client in case of emergency.
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When the Notes tab is chosen the following screen will appear:

This screen allows the user to enter notes about the client.

The notes can be up to 2 pages long.

Field Description

Notes This screen allows for detailed information to be
stored for each client.
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Report Viewer

The Report Viewer is a general purpose utility that allows the user to view reports on

the screen instead of printing the report on hard copy.

The printer setup screen can be used to turn on the report viewer for all reports. When

the �ReportViewer� check box is checked reportswill be routed to the report viewer.

The Report viewer screen displays the report as it is generated the first (5) or nine (9)

lines of the screen are used to display the report heading. (nine lines are usedwhen the

report width is less than eighty (80) characters). The thumb bar on the screen can be

used to scan through the report as it is generated.

The report viewer title bar shows the report title prefaced by the current activity. The

activity may be one of three values:

n Generating - This value indicates that the report program is processing data and
creating the report.

n Viewing - This value indicates that the report program has completed it's
processing and the complete report is available.

n Printing - This value indicates that the program is printing the report to a
printer.
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The Report Viewer menu bar has three menu selections under the �File� choice:

n Print To Default - This option will print the report in the viewer to the
workstations default printer using the default font from the printer setup screen.

n Print To Selected - This option will print the report after allowing the user to
select the printer and font.

n Exit - This option is used to exit the report viewer. When the viewer is showing
the generating activity the report program will be canceled and the viewer
window will close down. When the viewer is showing the printing activity the
report printing will be canceled but the viewer window will remain open.

When viewing the report the heading lines will remain at the top of the screen and the

report body will scroll in the lower portion of the window. The windowmay be sized

to show more of the report data.

The report body is presented without any page breaks unless the program generating

the report has requested a new page for some logical subdivision of the report. The

page break is represented by a �page break� line in the report body.
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Limitations

When the program generating the report uses dynamic page formatting based on the

printer, font, and paper type selected by the user, the printing of the report from the

page viewermaynot duplicate the results obtainedwhen the report is printed directly.

The report viewer obtains the page formatting information by assuming the report will

be printed on the workstation default printer using the default font.

If the printer setup screen has the select printer and select font options turned on the

report viewer will request a printer and font selection at the start of the report

generation activity. The choices made will determine the page formatting used by the

report viewer.

The choices made for the printer and font are not preserved for the printing of reports

by the report viewer. They are only used to determine the page format for the

on-screen display of the report.
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Homecare Control Settings

When the Homecare Control Settings is selected from the Schedule menu bar the

following screen will appear:

The following fields appear in the dialog box:

Field Description

Start Date This field contains the default start date for the
homecare schedule processing.

Days to Schedule This field contains the default number of days for
the homecare schedule processing.
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Homecare Reports

The Homecare Reports menu from the schedule menu bar is used to print Homecare

reports from the home care data.

The Homecare Reports menu appears as follows:

F Homecare Reports

n Homecare Employee Worksheet

n Homecare Employee Week

n Homecare Employee Month

n Homecare Employee Seniority

n Homecare Client Worksheet

n Homecare Client List

n Homecare Client Schedule

n Homecare Client Week

n Homecare Client Month
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Homecare Employee Worksheet

The Homecare Employee Worksheet option prints the homecare employee

worksheet showing the scheduled clients.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report.

A single employee schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Report
Information

This report prints the schedule items for the employee by area or by employee. A new

employee worksheet page will be started for each new area, employee, or new month

and year.

This report uses underlining to produce the worksheet, this may determine which

printer font you wish to select. The report will produce the worksheet in 4, 8, 12 or 24

hour portions depending on the font chosen as this determines the printable length of

the line.

This report will show all the scheduled items that have not had an employee assigned

to them grouped by area and month. There may be multiple scheduled items per day

and the report may print several lines per day if the scheduled items overlap. The

unassigned schedule worksheet page will be printed first.

This report will show all the scheduled items per employee and will have the hours

blocked out that the employee is available for work. This will look first for the

preferred time, then to the available time. The employeeworksheet page rangewill be

from the first to the last hour available or scheduled. When the employee is

unavailable the time slot will be stroked out. Canceled scheduled items will not be

printed. A total of the available hours and scheduled hours permonth are printed in the

heading.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment
will be printed on the report.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Employee

n Area

Single Employee
Option

To choose a single employee option for the Homecare EmployeeWorksheet select the

Single Employee object.

For instructions on how to select single employee option refer to the common selection

screen chapter in the Schedule manual.

Selected Area
Selection

To choose areas for theHomecareEmployeeWorksheet select the select areas object.

For instructions on how to select area refer to the common selection screen chapter in

the Schedule manual. If you have selected area the message Exclude selections or

Include selections will be displayed beside the selection button when you return to the

select report objects dialog box.
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Homecare Employee Week

The Homecare Employee Week option prints the homecare employee activity per

week showing the scheduled clients.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report. A single employee schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.

F If the employee has no activity for that day the report will display the message that the
employee is unassigned. If the employee has an availability record for that day the
times the employee is available will be printed with the unassigned message.

Can-Pay Computer Software 292

HOMECARE - 6



Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment
will be printed on the report.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Employee

n Area

Single Employee
Option

To choose a single employee option for the Homecare Employee Week select the

Single Employee object.

For instructions on how to select single employee option refer to the common selection

screen chapter in the Schedule manual.

Selected Area
Selection

To choose areas for the Homecare Employee Week select the select areas object.

For instructions on how to select area refer to the common selection screen chapter in

the Schedule manual. If you have selected area the message Exclude selections or

Include selections will be displayed beside the selection button when you return to the

select report objects dialog box.
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Homecare Employee Month

The Homecare Employee Month option prints the homecare employee activity for

the month showing the scheduled clients.

This function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report.

A single employee schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.

F The report is printed in a calendar format showing the date, start and end time, the
client and the activity under the correct day of the week column. If the report page is
wide enough the length of the activity will be printed.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment
will be printed on the report.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Employee

n Area

Single Employee
Option

To choose a single employee option for the Homecare Employee Month select the

Single Employee object.

For instructions on how to select single employee option refer to the common selection

screen chapter in the Schedule manual.

Selected Area
Selection

To choose areas for the Homecare Employee Month select the select areas object.

For instructions on how to select area refer to the common selection screen chapter in

the Schedule manual. If you have selected area the message Exclude selections or

Include selections will be displayed beside the selection button when you return to the

select report objects dialog box.
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Homecare Seniority Listing

The Homecare Seniority option prints the seniority list by area.

The report format is an area listwith seniority details, just a seniority list or just the area

and seniority list names with no employee details.

The function allows the user to select the date range for the report, the data fields to

include in the report, to select a single seniority list or area page breaks, send report to

printed or screen and report format.

Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields:

Field Description

Hours This field is used to show the number of seniority
hours per employee.

Order This field is used to show the order within the group
of employees with the same number of hours.
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The following dialog box appears when the options tab is chosen:

Selected Area
Selection

To choose areas for the Homecare Seniority Listing select the select areas object.

For instructions on how to select area refer to the common selection screen chapter. If

you have selected area the message Exclude selections or Include Selections will be

displayed beside the selection button when you return to the select report objects

dialog box.

Single Seniority
List Option

To choose single seniority list option for the Homecare Seniority Listing select the

single seniority list object.

For instructions on how to select single seniority list refer to the common selection

screen chapter in the Schedule manual.
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When the printer tab is chosen the following screen will appear:

Page Break
Selection

The page break selection for the report allows for the following page break selections.

n No

n Yes

Print To Selection The Print To Selection for the report allows for the following report to be printed to the

report or on the screen.

n Printer

n Screen
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The following dialog box will appear when the format tab is chosen:

Report Format
Selection

The sort order selection for the report allows for the following format selections:

n Area Summary Only

n Seniority Lists Only

n Area with Seniority Lists

The report format selection for the report allows for the inclusion of the following data

fields:

Field Description

Area Summary Only This field is used to print the area list showing the
seniority list code names only.

Seniority List Only This field is used to print only the seniority list
selected.

Area Seniority Lists This field is used to print the areas selected with
the seniority list code names as well as all the
employee details.
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Homecare Client Worksheet

The Homecare Client Worksheet option prints the homecare client worksheet

showing the scheduled employees.

The function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report.

A single client schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Report
Information

This report prints the scheduled items for the client by area or by clients. A new client

worksheet pagewill be started for each newarea, employee, or newmonth and year.

This report uses underlining to produce the worksheet, this may determine which

printer font youwish to select. The report will produce theworksheet in 4, 8, 12 or 24

hour portions depending on the font chosen as this determines the printable length of

the line.

This report will show all the scheduled items, those that have an employee assigned to

them will show the employee name. There may be multiple scheduled items per day

and the report may print several lines per day if the scheduled items overlap. All

canceled scheduled items will be shown as canceled. A total of the scheduled hours is

printed in the heading. The client worksheet page range will be from the first to last

hour scheduled.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment will be printed
on the report.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Client

n Area

Single Client
Option

To choose single client option for the Homecare Client Worksheet select the single

client object.

For instructions on how to select single client refer to the common selection screen

chapter in the Schedule manual.

Area Selection To choose areas for the Homecare Client Worksheet select the area selection option in

the File menu.

For instructions on how to select area selection option refer to the common selection

screen chapter in the Schedule manual.
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Homecare Client List

The Homecare Client List option prints the client list.

The function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report.

A single client list may be selected. The report allows for the options of printing the

activity schedules and the employee assignments.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Report Options This report prints the client list by area or by client. A newpagewill be started for each

client if the activity schedule and the assigned employee are requested. The client's

name is always printed on a report. This report requires a font that will produce a

minimum of 100 characters per print line. If no activities are found a message �no

activities scheduled� will be printed. If no employees are found a message �no

employee assigned� will be printed.

The print option for the report allows for the following print option selections

n Show Activity Schedules

n Show Employee Assignments

F Activity Schedule

The following fields are printed for each activity

n activity name and position

n up to six weeks for the schedule if available

n up to 3 time slots per day if available

n for each week the starting and ending time is printed for each day

F Employee Assignments

The following fields are printed for each employee assignment

n employee name

n start dates

n end dates

n days in the month

n hours per day

n starting time

n ending time

If the activity schedule is not being printed the activity name&positionwill be printed

for each employer.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Field Description

Address 1 address line 1

Address 2 address line 2

City name of city

Province 2 character province code

Postal Code postal code

Account client account number

Home Phone home phone number

Alt Phone alternate phone number

Area area of client

Medical medical insurance number

Family Medical family medical insurance number

S.I.N. social insurance number

Birth Date client birth date

Sex male or female (Y or M)

Treaty treaty number

Band band number

Notes notes on client

Contact contact

Emer Phone emergency phone number

Physician name of physician of client

Relation the relation to client

The print options are selected by clicking on the box before the desired print option

with themouse once, this optionwill be includedwhen the box by the field has a check

mark.

To de-select the print options click on the box before the desired optionwith themouse

and the check mark will disappear.
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The following dialog box appears when the select tab is chosen:

Selected Area
Selection

To choose areas for the Homecare Client List select the select areas object.

For instructions on how to select area refer to the common selection screen chapter. If

you have selected area the message Exclude selections or Include selections will be

displayed beside the selection button when you return to the select report objects

dialog box.

Single Client
Option

To choose single client option for the Homecare Client List select the single client

object.

For instructions on how to select single client refer to the common selection screen

chapter in the Schedule manual.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen
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The following dialog box appear when the sort tab is chosen:

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Client

n Area
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Homecare Client Schedule

The Homecare Client Schedule option prints the client list.

The function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report.

A single client list may be selected. The report allows for the options of printing the

activity schedules and the employee assignments.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

The Report field selection allows for inclusion of the following data fields:

Field Description

Client When this field is checked the name of the client having the client schedule
item will be printed on the report.

Date When this field is checked the date for the client schedule item will be printed
on the report.

Start Time When this field is checked the starting time for the client schedule item will be
printed on the report.

End Time When this field is checked the ending time for the client schedule item will be
printed on the report.

Area When this field is checked the area for the client schedule item will be printed
on the report.

Sub Area When this field is checked the sub area for the client schedule item will be
printed on the report.

Activity When this field is checked the activity for the client schedule item will be
printed on the report.

Sub Activity When this field is checked the sub activity for the client schedule item will be
printed on the report.

Badge When this field is checked the badge number of the employee having the client
schedule item will be printed on the report.

Hours When this field is checked the hours for the client schedule item will be printed
on the report.

Position When this field is checked the position for the client schedule item will be
printed on the report.

Reason When this field is checked the reason for the client schedule item will be printed
on the report.

Shift When this field is checked the shift for the client schedule item will be printed
on the report.

Employee When this field is checked the employee for the client schedule item will be
printed on the report.

Account When this field is checked the account for the client schedule item will be
printed on the report.

The print options are selected by clicking on the box before the desired print option

with themouse once, this optionwill be includedwhen the box by the field has a check

mark.
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The following screen will appear when the sort tab is chosen:

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Client

n Area

Page Break The page break selection for the report allows for the following page break selections.

n No

n Yes

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen
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The following screen will appear when the select tab is chosen:
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Select Report
Objects

The Select Report Objects selection for the report allows for the following selection

options:

Shift For instructions on how to select shifts refer to page 11 of the common selection screen

chapter. If you have selected shifts the message Exclude selections or Include

selections will be displayed beside the SELECT SHIFTS button when you return to the

select report objects dialog box.

Position For instructions on how to select positions refer to page 9 of the common selection

screen chapter. If you have selected positions the message Exclude selections or

Include selections will be displayed beside the SELECT POSITIONS button when you

return to the select report objects dialog box.

Reason For instructions on how to select reasons refer to page 10 of the common selection

screen chapter. If you have selected reasons themessageExclude selections or Include

selections will be displayed beside the SELECTREASON button when you return to the

select report objects dialog box.

Area For instructions on how to select area refer to page 5 of the common selection screen

chapter. If you have selected area the message Exclude selections or Include

selections will be displayed beside the SELECT AREA button when you return to the

select report objects dialog box.

Sub Area For instructions on how to select sub area refer to page 16 of the common selection

screen chapter. If you have selected sub area the message Exclude selections or

Include selections will be displayed beside the SELECT SUB AREA button when you

return to the select report objects dialog box.

Activity For instructions on how to select activity refer to page 4 of the common selection

screen chapter. If you have selected activity themessageExclude selections or Include

selectionswill be displayed beside the SELECTACTIVITYbuttonwhen you return to the

select report objects dialog box.

Sub Activity For instructions on how to select sub activity refer to page 15 of the common selection

screen chapter. If you have selected sub activity the message Exclude selections or

Include selections will be displayed beside the SELECT SUB ACTIVITY button when

you return
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Homecare Client Week

The Homecare Client Week option prints the homecare client weekly activities

showing the scheduled employees.

The function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report. A single client schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.
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Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment will be printed
on the report.

Twelve Hour When this field is checked, the time will be printed as am or p.m. not the 24
hour clock.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Client

n Area

Single Client
Option

To choose single client option for the Homecare Client Week select the single client

object.

For instructions on how to select single client refer to the common selection screen

chapter in the Schedule manual.

Area Selection To choose areas for the Homecare Client Week select the area selection option in the

File menu.

For instructions on how to select area selection option refer to the common selection

screen chapter in the Schedule manual.
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Homecare Client Month

The Homecare Client Month option prints the homecare client monthly activities

showing the scheduled employees.

The function allows the user to select the date range for the report, the data fields to

include in the report, the sort order for the report, and to select the areas to include or

exclude in the report. A single client schedule worksheet may be selected.

Saving... The selectionsmade by the user can be saved by selecting theSaveParameters option

in the File menu.

Can-Pay Computer Software 322

HOMECARE - 6



Date Range
Selection

To limit the range of the report the starting and ending dates may be entered. If both

dates are zero the entire report will be printed. If only the ending date is zero the report

will print from the starting date until the end of the report.

Data Field
Selection

A data field is selected for the report when the box to the left of the field has a check

mark.

The data field selection for the report allows for the inclusion of the following data

fields.

Data Field Description

Activity When this field is checked, the activity for the work segment will be printed
on the report.

Twelve Hour When this field is checked, the time will be printed as am or p.m. not the 24
hour clock.

Print To Selection The Print To selection for the report allows for the following report to be printed to the

printer or on the screen.

n Printer

n Screen

Sort Order
Selection

The sort order selection for the report allows for the following sort order selections.

n Client

n Area

Single Client
Option

To choose single client option for the Homecare Client Month select the single client

object.

For instructions on how to select single client refer to the common selection screen

chapter in the Schedule manual.

Area Selection To choose areas for the Homecare Client Month select the area selection option in the

File menu.

For instructions on how to select area selection option refer to the common selection

screen chapter in the Schedule manual.
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Accumulators

The Payroll Accumulator Selection screen allows you to select accumulators from the

list of activities displayed.

The dialog box for the Payroll Accumulator Selection appears as follows:

The accumulators are selected by clicking on the desired accumulator with the mouse

once, this accumulator will now be highlighted. Any number of accumulators may be

selected by repeating this procedure.

When all the desired accumulators are selected click on the OK button.

To de-select a single accumulator simply click on the highlighted accumulator and it

will no longer be selected. To de-select all the selected accumulators click on theClear

Selection object.

When you are selecting certain accumulator you may include or exclude all the

selected accumulators in the report. This is done by clicking on the Include or Exclude

object.
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Deductions

The Payroll Deduction Selection screen allows you to select deduction from the list of

deductions displayed.

The dialog box for the Payroll Deduction Selection appears as follows:

The deductions are selected by clicking on the desired deductions with the mouse

once, this deduction will now be highlighted. Any number of deductions may be

selected by repeating this procedure.

When all the desired deductions are selected click on the OK button.

To de-select a single deduction simply click on the highlighted deduction and it will no

longer be selected. To de-select all the selected activities click on the Clear Selection

object.

When you are selecting certain deductions youmay include or exclude all the selected

activities in the report. This is done by clicking on the Include or Exclude object.
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Select Activity Selection

The Select Activity Selection screen allows you to select activities from the list of

activities displayed.

The dialog box for the Activity Selection appears as follows:

The activities are selected by clicking on the desired activities with the mouse once,

this activity will now be highlighted. Any number of activities may be selected by

repeating this procedure.

When all the desired activities are selected click on the OK button.

To de-select a single activity simply click on the highlighted activity and it will no

longer be selected. To de-select all the selected activities click on the Clear Selection

object.

When you are selecting certain activities you may include or exclude all the selected

activities in the report. This is done by clicking on the Include or Exclude object.
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Select Area Selection

The Select Area Selection screen allows you to select areas from the list of areas

displayed.

The dialog box for the Area Selection option appears as follows:

The areas are selected by clicking on the desired area with the mouse once, this area

will now be highlighted. Any number of areas may be selected by repeating this

procedure.

When all the desired areas are selected click on the OK button.

To de-select a single area simply click on the highlighted area and it will no longer be

selected. To de-select all the selected areas click on the Clear Selections object.

When you are selecting certain areas youmay include or exclude all the selected areas

in the report. This is done by clicking on the Include or Exclude object.
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Select Earnings Selection

The Select Earnings selection allows you to select earnings from the list of earnings

displayed.

The dialog box for the Earnings Selection appears as follows:

The earnings are selected by clicking on the desired earnings with themouse once, the

earning will now be highlighted. Any number of earnings may be selected by

repeating this procedure.

When all the desired earnings are selected click on the OK button.

To de-select a single earning simply click on the highlighted earning and it will no

longer be selected. To de-select the all selected earnings click on the Clear Selection

object.

When you are selecting certain earnings you may include or exclude all the selected

earnings in the report. This is done by clicking on the Include or Exclude object.
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Select Grand Master Payroll File

One of these payrolls must be selected for scheduling. The payroll is selected by

placing the cursor over the payroll and clicking on the left-hand mouse button. The

payroll selected will appear in the main menu screen.

The following dialog box appears:

Inserting a New Payroll

The INSERT button will allow the user to add a new payroll to the list of available

payrolls. To insert a new payroll the following steps should be taken:

1. Select theINSERTbutton.

2. Type in the name of the new payroll in the dialog box that appears and select
theOK button.

3. In the new dialog box type in the name, description, and path to payroll in the
proper fields.

4. In the payroll password if you click on the enable password the set password
button will be available.

5. Select theSaveoption from theFile menu and then select theOK button.

6. Your new payroll will now be displayed on the screen.
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Updating an Existing Payroll

If the UPDATE button is selected the user will be able to update the name, description,

and/or path to the payroll. To update the payroll follow these steps:

1. Select theUPDATE button.

2. A dialog box will appear which displays the name, description, and path to
payroll.  Make changes to the necessary fields.

3. Select the Save option from the File menu and then select theOK button.

4. In the payroll password if you click on the enable password the set password
button will be available.

Deleting an Existing Payroll

If the DELETE button is selected the user will be able to delete the payroll.

To delete the payroll follow these steps:

1. Select the DELETE button.

2. You are asked to confirm the delete.  Click on yes to delete the payroll.
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Select Positions Selection

The Select Positions Selection screen allows you to select positions from the list of

positions displayed.

The dialog box for the Position Selection appears as follows:

The positions are selected by clicking on the desired positionwith themouse once, this

position will now be highlighted. Any number of positions may be selected by

repeating this procedure.

When all the desired positions are selected click on the OK button.

To de-select a single position simply click on the highlighted position and it will no

longer be selected. To de-select all the selected positions click on the Clear Selections

object.

When you are selecting certain positions you may include or exclude all the selected

positions in the report. This is done by clicking on the Include or Exclude object.
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Select Reasons Selection

The Select Reasons Selection screen allows you to select reasons from the list of

reasons displayed.

The dialog box for the reason selection appears as follows:

The reasons are selected by clicking on the desired reason with the mouse once, the

reasonswill now be highlighted. Any number of reasonsmay be selected by repeating

this procedure.

When all the desired reasons are selected click on the OK button.

To de-select a single reason simply click on the highlighted reason and it will no longer

be selected. To de-select all the selected reasons click on theClear Selection object.

When you are selecting certain reasons you may include or exclude all the selected

reasons in the report. This is done by clicking on the Include or Exclude object.
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Select Shifts Selection

The Select Shifts Selection screen allows you to select shifts from the list of shifts

displayed.

The dialog box for the Shift Selection appears as follows:

The shifts are selected by clicking on the desired shifts with the mouse once, the shift

will now be highlighted. Any number of shifts may be selected by repeating this

procedure.

When all the desired shifts are selected click on the OK button.

To de-select a single shift simply click on the highlighted shift and it will no longer be

selected. To de-select the all selected shifts click on the Clear Selections object.

When you are selecting certain shifts youmay include or exclude all the selected shifts

in the report. This is done by clicking on the Include or Exclude object.

Can-Pay Computer Software XI

Common Selection Screens - 1



Select Single Client Selection

TheSelect SingleClient Selection screen allows you to choose to select only one client

from the list of clients displayed.

The dialog box for the client selection appears as follows:

Next Client Pressing the next button or selecting the next client option from the File menu will

bring up the next client in the list.

Previous Client Pressing the previous client button or selecting the previous client option from the File

Menu will go back to the previous client in the list.

F8 (List) Pressing the F8 key or selecting the list client option from the file menuwill bring up a

list of clients.

ESC (Exit) The ESC key will exit the user from the current screen.
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Select Single Employee Selection

The Select Single Employee Selection screen allows you to select only one employee

from the list of employees displayed.

The dialog box for the employee selection appears as follows:

Next Employee Pressing theNext button or selecting the next employee option from the Filemenuwill

bring up the next employee in the list.

Previous
Employee

Pressing the Previous button or selecting the previous employee option from the File

Menu will go back to the previous employee in the list.

F8 (List) Pressing the F8 key or selecting the list employee option from the file menu will bring

up a list of employees. The list will vary depending on whether or not a payroll has

been selected. If no payroll is selected all employees will appear in the list . However

if a payroll is selected only the employee in that payroll will appear in the list.

ESC (Exit) The ESC key will exit the user from the current screen.

The search technique that is set will change the order that the employees appear in the

list.
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Select Skill Selection

The Select Skills Selection screen allows you to select skills from the list of skills

displayed.

The dialog box skill selection appears as follows:

The skills are selected by clicking on the desired skill with the mouse once, this skill

will now be highlighted. Any number of skills may be selected by repeating this

procedure.

To de-select a single skill simply click on the highlighted skill and it will no longer be

selected. To de-select all the selected skills click on the Clear Selections button.

When you are selecting certain skills youmay include or exclude all the selected skills

in the report. This is done by clicking on the Include or Exclude objects.
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Select Subactivity Selection

The Select Subactivity Selection screen allows you to select subactivities from the list

of sub activities displayed.

The dialog for the Subactivity selection appears as follows:

The subactivities are selected by clicking on the desired subactivity with the mouse

once, this subactivity will now be highlighted. Any number of subactivities may be

selected by repeating this procedure.

When all the desired subactivities are selected click on the OK button.

To de-select a single subactivity simply click on the highlighted subactivity and it will

now longer be selected. To de-select all the selected subactivites click on the Clear

Selections object.

When you are selecting certain subactivities you may include or exclude all the

selected sub activities in the report. This is done by clicking on the Include or Exclude

object.
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Select Subarea Selection

The Select Subarea Selection allows you to select sub areas from the list of sub areas

displayed.

The dialog box for the Subarea selection appear as follows:

The subareas are selected by clicking on the desired subareaswith themouse once, this

subarea will now be highlighted. Any number of subareas may be selected by

repeating this procedure.

To de-select a single subarea simply click on the highlighted subarea and it will no

longer be selected. To de-select all the selected subareas click on the Clear Selections

object.

When you are selecting certain subareas you may include or exclude all the selected

subareas in the report. This is done by clicking on the Include or Exclude object.
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